Results 1 to 7 of 7
  1. #1

    Join Date
    Feb 2011
    Location
    Abu Dhabi, UAE
    Posts
    14

    Losing RPM on SHO

    Hi guys,

    I just had to rebuild the engines on two 2011's. One FZS and one FZR due to the tacho gear assembly breaking teeth and getting into the engine.
    Everything has gone smoothly, but I cannot get above 7100 RPM on either one.
    I'm hoping someone here has some suggestions, as I have tried everything under the sun, and can't get the units to above that 7100 RPM mark.

    Thanks,

    Sam


  2. #2
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Not knowing what else they have, when I had that issue I was not getting enough fuel

  3. #3

    Join Date
    Feb 2011
    Location
    Abu Dhabi, UAE
    Posts
    14
    Forgot to mention that both units are bone stock.

  4. #4

    Join Date
    Aug 2008
    Location
    Southern Florida
    Posts
    5,589
    +1
    345
    Using pet tach toi get your rpms??

    How about pitching prop??

    What kind a speeds you running on gps?

  5. #5
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    You said they were both rebuilt. Were they just removed, the pan removed and cleaned out or completely rebuilt?
    If not completely rebuilt I might suspect one of the connections. Not everything pops a code.

  6. #6

    Join Date
    Feb 2011
    Location
    Abu Dhabi, UAE
    Posts
    14
    They were completely rebuilt.

  7. #7
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Quote Originally Posted by samerone View Post
    They were completely rebuilt.
    Timing?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need to Increase RPMS on SHO
    By Spi200 in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 03-16-2016, 10:03 AM
  2. Ultra 250x loseing rpm on left turns
    By Richard John Rowe in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 02-24-2015, 05:46 AM
  3. 2013 fx sho not revving past 6500 rpm on full throttle
    By Derek009 in forum Yamaha PWC Performance (4-stroke)
    Replies: 15
    Last Post: 09-30-2014, 05:09 PM
  4. Signs that a Riva IC is busted? Missing Major RPMs on Stage 2+ SHO
    By poof100 in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 07-29-2011, 06:52 PM
  5. how high can these motors go (rpms) on stock valve train sho/fzr
    By wave15stx in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 06-20-2010, 02:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •