Results 1 to 8 of 8
  1. #1

    1994 SLT Stuck Prop

    Seems my prop is stuck. Tried to find a post but the search never resulted in anything. Can someone point me in the right direction?


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    Welcome to the Hulk.

    Can you share more info with us?

    Is there somethig wedging the impeller?

    Is the pump bearings seized?

    Have you removed the pump yet?

  3. #3
    While digging around to answer your questions I came across a golf ball size rock lodged in the the prop impellar. Disassembles and also found some sand, well, a lot of sand, lodged in between the seams...sorry, newbie here, not sure what the nomenclature is. Anyway, pulled out the impeller and shaft and cleaned it all up, removed the rock and she runs like a champ again. Thanks.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    Nice!!!!!!

    I just had a similar situation last week end.

    While tuning my ski, something MAJOR happened.

    When I revved the engine, it would rev, and I would BARELY move.

    Idled back to the launch, disassembled the pump on the beach and found a chop of wood the size of a cork lodged between the impeller and wear ring.

    Chiseled it out and went on my merry way. Probably totalling another 15 miles of riding that day.

    Moral of the story is:

    TAKE tools with you!!!!! It can be the difference between having a long fun day at the beach, or a short day and upsetting experience.

  5. #5
    Thanks. Always do...used to own a VW bug so I got into the habit of tool toting with that...matter of fact, I traded my last bug for the ski...best trade I ever made. Have a lot to learn, but having a blast on the way!

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31

  7. #7
    Saved forever! Thanks.

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    There are invauable links posted at the bottom of K447 posts.

    Make sure to click on them as well

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1994 SLT 750 Polaris running to rich
    By tommy73 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 04-21-2009, 09:34 PM
  2. 1994 Slt 750 > Parts
    By mjlaforest in forum Polaris Classifieds
    Replies: 6
    Last Post: 09-02-2008, 02:28 PM
  3. Stuck prop on the shaft again
    By Lvnspeed in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 11-24-2007, 09:29 AM
  4. 1994 slt stator replacement
    By tallyhoe in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 07-14-2007, 11:40 AM
  5. The worst stuck prop ever!
    By Robsauto2 in forum Yamaha PWC Performance (2-stroke)
    Replies: 28
    Last Post: 07-05-2007, 11:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •