Results 1 to 10 of 10
  1. #1
    kegonsa's Avatar
    Join Date
    Aug 2010
    Location
    Stoughton
    Posts
    69

    What is this in my carbs? And check out Grandma

    So as I have posted before my jet ski will hit about 3800 to 4200 and and wont pull. Some times it will it will pull out others you feather the gas and it goes away. I thought it might be my exhaust pipe because there were huge bubbles in it when it was cold. I replaced that and it seemed to run fine on the test ride and most of the day today until the end. I just rebuilt the carbs this winter. It was the first time I have done this and figured I would start back there. I started taking it apart and found this foamy milky stuff in my carbs. Any idea on what causing this?

    Click image for larger version. 

Name:	SL734677.jpg 
Views:	84 
Size:	65.6 KB 
ID:	246017Click image for larger version. 

Name:	SL734679.jpg 
Views:	92 
Size:	68.8 KB 
ID:	246018Click image for larger version. 

Name:	SL734678.jpg 
Views:	97 
Size:	88.2 KB 
ID:	246019


    My 90 year old grandma wanted to get out on the jet ski, lucky for her it was still running fine.
    Click image for larger version. 

Name:	tim and grandma on jet ski.jpg 
Views:	134 
Size:	73.0 KB 
ID:	246020


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    90???? She looks good for 90!!!!

    "Hey bebe"



    As for the milky stuff, that's water mixed with 2 stroke oil/gas

    As your carbs spit a little fuel out the top, it mixes with any water you have inside the hull and makes that milky mess.

    You do have a Flame arrestor installed correct?

  3. #3
    kegonsa's Avatar
    Join Date
    Aug 2010
    Location
    Stoughton
    Posts
    69
    It is just the stock flame arrestor and cover with the two bolts, unless one side of the FA has an up side. I have no gasket between the carbs and the FA tray.

    Could that be what is causing my ski to cut out?

  4. #4
    Check bilge pump and any water in your fuel system

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    If you have the stock 780 FA with the skirt that covers most of the element, you shouldn't see that much water.

    Definately check your water seperator.

    If the orange ring is floating, there's water present.

    Water in fuel will cause performance issues for sure.

  6. #6
    Every marine fuel system should have that same set up,It makes checking water in the fuel a 5 second job.

  7. #7
    kegonsa's Avatar
    Join Date
    Aug 2010
    Location
    Stoughton
    Posts
    69
    The red ring is sitting on the bottom. I will take it off and check it to be safe.
    Pulled the carbs out of the jet ski yesterday and hope to have time to go through and clean/inspect the rebuild that I did on them tomorrow.

    Man this week is HOT.

  8. #8
    kegonsa's Avatar
    Join Date
    Aug 2010
    Location
    Stoughton
    Posts
    69
    Well this sucks, I had finished cleaning my carbs and was doing the pop-off should have done it the first time). I was on the last carb for the mag and it kept on bubbling and it was going at like 15. I switched back to my old needle valve assembly and same thing Checked the screw for the plate that holds it and it was lose, turned it and it snapped the head off. I was not cranking on the crews or anything.

    Not sure if I am going to drill and tap or not.

    would the carbs friscoboater has for sale work on mine? they are from a SLX 780. I know the high and low settings are different, would I have to adjust because of the different style FA?

  9. #9
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    Try an easy out first.

    But yes, Frisco's carbs would work.

  10. #10
    kegonsa's Avatar
    Join Date
    Aug 2010
    Location
    Stoughton
    Posts
    69
    I cant find one small enough, fastenal is getting a left had drill bit. Hope that works.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Look what I found in my carb filters.....What is it?
    By MPower in forum 2-Stroke Performance
    Replies: 12
    Last Post: 06-06-2016, 12:13 PM
  2. What is this?? Flakes on TB and factory ribbon.
    By Slamdcoop0428 in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 09-12-2014, 05:18 AM
  3. Hmmm...what is this under my footwell mats on my Ultra 300?
    By jetdave56 in forum Kawasaki Open Discussion
    Replies: 12
    Last Post: 04-24-2014, 07:02 PM
  4. WTF is this in my IC?
    By Alex13 in forum 4-Tec Performance
    Replies: 41
    Last Post: 12-14-2008, 10:29 PM
  5. What is this on my RXP?
    By vidbuster in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-11-2007, 09:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •