Results 1 to 6 of 6
  1. #1
    98gsxl951's Avatar
    Join Date
    Jul 2008
    Location
    On my ski, on the CT river
    Posts
    879
    +1
    3

    so my venturi/exit nozzle came loose at wot on my rxpx....

    so the dude before me did a grate, impeller, and riva wedge. im taking who ever installed it half ass'd it because this saturday at wot, i hit a small boats wake, maybe got a ft out of the water, and when i came down, it was like hitting a wall. ski stopped i went flying. thought my motor locked up or something. get back on ski inspect the engine bay everything looks ok no, smoke or anything, ski starts up, but will barely go anywhere and my reverse lever keeps popping up. limp it to shore finally, check the pump area, low an behold, im missing a bolt, another one sheered off, ones back out about 1/8 " and bent, and the 4th is there but the ear broke off the venturi portion of the exit nozzle ... sweet. so luckily i had a 6mm allen and was able to get one side of the pump buttoned up as much as a i could. to limp it to the launch 3 miles away.

    heres the part that i am stumped about now. so pull the corks, and water just starts pissing out the hull ( usually only a few drops come out after a days riding. ) and keeps coming out, gonna say a gallon maybe 2 of water, it had to been all the way to the gas tank area, cause the next day we tipped the trailer up and another 1/2 gallon or less came out.

    what are your guys thoughts on this water? my ski is at my buddies shop getting a overhaul done any way, ( SC rebuild, viton seals, 4" kani flex, FF exhaust, rxp nozzle) carbon seal is being done regardless, he is going to inspect the pump tunnel area thoroughly as well, when i got there he did look around and from the out side looked ok.

    thoughts on the water that came into hull?


  2. #2
    mac_man_luke's Avatar
    Join Date
    Sep 2010
    Location
    South Australia
    Posts
    1,262
    +1
    22
    most likely through the bailer tubes (most likely came out of the nozzle when it moved)

    they become water injectors when not located correctly

  3. #3
    98gsxl951's Avatar
    Join Date
    Jul 2008
    Location
    On my ski, on the CT river
    Posts
    879
    +1
    3
    can you elaborate please? you mean the 2 tubes at the top ? the look like they squirt downwards?

  4. #4
    szt8b7's Avatar
    Join Date
    Jul 2010
    Location
    Shreveport, LA
    Posts
    661
    +1
    6
    Yup. They are maybe 1/4" diameter right at the top of your nozzle. I would guess when the nozzle came loose it forced water back up the tubes where they normally join up at the pump/nozzle seam. Not really knowing the history of the ski (at least if anything else was jacked up prior to you) I'd consider a bilge pump also. Pretty easy to install and not much $$$$.

  5. #5
    98gsxl951's Avatar
    Join Date
    Jul 2008
    Location
    On my ski, on the CT river
    Posts
    879
    +1
    3
    the ski never had water in the 45 hours ive put on so far this season. this is the first time ive seen it happen. regardless the CT watercraft will be going through the whole ski, and get back to me. hopefully its only those tubes, or just the carbon seal that went bad.

  6. #6
    szt8b7's Avatar
    Join Date
    Jul 2010
    Location
    Shreveport, LA
    Posts
    661
    +1
    6
    I would guess you are good. I have 45 hours on my 09 X and no leaks either.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Acceptable AFR at WOT on SHO or SVHO?
    By OutlawGPR in forum Yamaha PWC Performance (4-stroke)
    Replies: 14
    Last Post: 07-15-2016, 02:15 PM
  2. Solas nose cone came loose.. leave it on or take it off?
    By Tbranella in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-10-2016, 09:44 AM
  3. Nozzle ring came loose
    By adrenalinjunkie in forum 4-Tec Performance
    Replies: 32
    Last Post: 11-21-2011, 09:57 PM
  4. Blown Steering and exit nozzle at near 80 on T-X!
    By Water4fire in forum 4-Tec Performance
    Replies: 26
    Last Post: 01-27-2010, 08:43 AM
  5. WTB SHO/FZR exit nozzle/venturi - Not steering
    By mrbtd in forum Yamaha Classifieds
    Replies: 1
    Last Post: 06-15-2009, 01:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •