Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    Care to take a gander at these plugs?

    New to me '99 Ultra 150.

    WOT I get 6000-6200 rpm. Trying to figure out where to go from here.

    Fresh rebuild with sbt crank/pistons/jugs. Stock heads/carb/airbox/etc.

    1st tank was on premix and BR8ES plugs. 2nd tank was on straight 91 and the correct plugs. Below is what they look like after a full tank. I ran another half a tank through since then but haven't uploaded pictures yet. Plugs have the same characteristics but with more color.

    So what do you think. Plugs are #1,2,3 from Right to left.






  2. #2
    After another 1/2 tank of gas.


  3. #3
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,007
    +1
    282
    Looks awfully lean, especially for break-in.

  4. #4
    Quote Originally Posted by steve45 View Post
    Looks awfully lean, especially for break-in.
    You mentioned break in - these plugs haven't seen any premix if it matters.

  5. #5
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,007
    +1
    282
    I like the one on the left in the last picture. The others are lean.

    You only ran one tank of pre-mix for break-in? Also, you don't need 91 octane fuel with stock heads.

  6. #6
    Quote Originally Posted by steve45 View Post
    I like the one on the left in the last picture. The others are lean.

    You only ran one tank of pre-mix for break-in? Also, you don't need 91 octane fuel with stock heads.
    Yup, only ran one tank of pre-mix. Should I have run more? If so I'll go back to premix although I have had a full tank of straight gas already through it.

    Good to know about not needing 91 octane. I've been looking into that this week. After reading the service manual and seeing that run time for WOT is 1 hour 9 minutes and premium is not needed - I've decided 87 octane it is.

  7. #7
    looks lean to me ! be good to know what bike and motor but if not dfi then you could end up rebuilding again, too lean for me.

  8. #8
    Quote Originally Posted by 123456 View Post
    looks lean to me ! be good to know what bike and motor but if not dfi then you could end up rebuilding again, too lean for me.
    '99 Ultra 150 - rookie mistake. Original post edited.

  9. #9
    Did you pull those plugs after doing a plug chop ?? WOT, pull lanyard, pull plugs. Aren't they supposed to be Br9's ??? And if your machine is before a certain serial number your supposed to be using the R6918C-9.. Do a compression check.

  10. #10
    Quote Originally Posted by Chris288 View Post
    Did you pull those plugs after doing a plug chop ?? WOT, pull lanyard, pull plugs. Aren't they supposed to be Br9's ??? And if your machine is before a certain serial number your supposed to be using the R6918C-9.. Do a compression check.
    Unfortunately it wasn't after a plug chop. I'll try to find a place to do that. Everywhere close by has a least a couple hundred foot no wake zone to get to land. I haven't felt like changing them on the water. Unfortunately the plugs in the pictures are R6918C-9's.

    Compression is 115-115-120. I've been checking it after every tank of gas or more.

    Also - anyone think the #2 plug having clean metal for 2/3 of the plug is odd? #1 & #3 are sooty all the way around.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Look at these spark plugs....and some thoughts
    By oikonomoupetros in forum 4-Tec Performance
    Replies: 15
    Last Post: 04-27-2015, 01:31 PM
  2. Please look at these Spark plugs, opinions HELP
    By jwaked in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 08-21-2014, 09:08 PM
  3. Take a look at these cylinder pics. Pics of Wossner pistons added .
    By duudu in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 11-18-2013, 04:44 PM
  4. Would you consider these plugs to be 'fouled'?
    By TheEngineer in forum 4-Tec Performance
    Replies: 17
    Last Post: 07-29-2010, 09:42 PM
  5. Someone try to read these plugs
    By roost5o in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-17-2008, 06:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •