Results 1 to 5 of 5
  1. #1

    Can Any one help me PLEASE

    Need help new to the pwc bought a polaris sl 750 getting no spark what do i need to do THANKS


  2. #2
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    Make sure the battery is good and fully charged and check to see if you have spark in any of the plugs don t just check one

  3. #3
    ok great thanks i only checked one and it has a brand new battery anything else

  4. #4
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    If you have spark in any other plugs then its either the coil or unscrew the boot and see if the wire is burnt in there. you might be able to get away with cutting the end of the wire off and screwing the boot back on. if you dont have spark at any, it could be all 3 wires are burnt, or a list of other things you'll have to test for but that is a good start. I always like to check for the easy fixes first

  5. #5
    thanks a whole bunch

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help 1996 SL700 weak spark its driving me crazy can any one help
    By JDLHP in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-22-2014, 04:30 PM
  2. Polaris msx110 shuts off every 5-10 minutes can any one help
    By nypogodee in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-22-2012, 07:36 PM
  3. Replies: 2
    Last Post: 08-23-2011, 09:51 AM
  4. can any one help me
    By undertaker1 in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 07-19-2011, 05:39 PM
  5. Can some one help me id this part?
    By great lakes gpr 1200 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 04-29-2006, 08:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •