Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    STALKER FZR's Avatar
    Join Date
    May 2011
    Location
    Smyrna, Delaware, United States
    Posts
    424

    Boost Leak, Bad Guage, or what?

    I recently installed a HKS BOV and boost guage. I had a real hard time seating the C-Clip, and I nicked up the flange a little before finally getting it in. I had my ski out last Sunday and noticed that under WOT, I was only getting 5.5-6.5 psi. I was into the soft limiter (Stock Prop w/ Stock Pitch). The ski does not feel any slower, but I thought my boost should be up around 7-8 psi. WTF is going on here? Thanks guys.


  2. #2
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    I'm pretty sure 5.5-6.5 is what the stock wheel runs at. Keep in mind, your still on stock ecu and stock IC. That's probably why you see a bit of heatsoak. To see if the bov is leaking, run with the seats off and put your hand in front of it. Hope that helps.

  3. #3
    STALKER FZR's Avatar
    Join Date
    May 2011
    Location
    Smyrna, Delaware, United States
    Posts
    424
    Quote Originally Posted by mikeFZR View Post
    I'm pretty sure 5.5-6.5 is what the stock wheel runs at. Keep in mind, your still on stock ecu and stock IC. That's probably why you see a bit of heatsoak. To see if the bov is leaking, run with the seats off and put your hand in front of it. Hope that helps.
    Will do...Thanks Mike. That makes me feel better.

  4. #4
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    Quote Originally Posted by mikeFZR View Post
    I'm pretty sure 5.5-6.5 is what the stock wheel runs at. Keep in mind, your still on stock ecu and stock IC. That's probably why you see a bit of heatsoak. To see if the bov is leaking, run with the seats off and put your hand in front of it. Hope that helps.
    Or he could just throw some soapy water on it while still on the trailer and if you see bubbles well then you have a boost leak

  5. #5
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    5.5-6.5 is correct on a bone stock ski with the stock restrictive air box.

  6. #6
    Lightning Struck's Avatar
    Join Date
    May 2011
    Location
    Davenoprt Iowa
    Posts
    714
    +1
    10
    Quote Originally Posted by hitman View Post
    5.5-6.5 is correct on a bone stock ski with the stock restrictive air box.
    He's not running the stock air box tho.

  7. #7
    mjh3ides's Avatar
    Join Date
    Jul 2007
    Location
    Jupiter, Florida
    Posts
    6,795
    +1
    2,010
    I always saw ~7psi with a Riva intake & manifold upgrade. My guess is you're banging the limiter pretty hard with the stock prop & it's dropping your revs & boost.

  8. #8
    STALKER FZR's Avatar
    Join Date
    May 2011
    Location
    Smyrna, Delaware, United States
    Posts
    424
    Quote Originally Posted by Lightning Struck View Post
    He's not running the stock air box tho.
    ...and I have done the ribbon delete.

  9. #9
    STALKER FZR's Avatar
    Join Date
    May 2011
    Location
    Smyrna, Delaware, United States
    Posts
    424
    Quote Originally Posted by mjh3ides View Post
    I always saw ~7psi with a Riva intake & manifold upgrade. My guess is you're banging the limiter pretty hard with the stock prop & it's dropping your revs & boost.
    I'm hoping thats what it is...I'm taking the ski out today to experiment a little.

  10. #10
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Quote Originally Posted by Lightning Struck View Post
    He's not running the stock air box tho.
    Woops. Now I see that in his signature. Should have looked before I posted. Go with what MJH is saying. He's my hero.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Video of how I check for Boost leaks on a Ultra 300 or 310
    By rod_rod in forum Kawasaki How To & FAQs
    Replies: 7
    Last Post: 05-12-2016, 02:50 PM
  2. Replies: 9
    Last Post: 08-04-2015, 07:03 PM
  3. What are symptoms of a boost leak?
    By Jarrett in forum 4-Tec Performance
    Replies: 16
    Last Post: 10-01-2009, 09:31 PM
  4. Bad Carbon Seal ?? Or What.......
    By NottaPhireMan in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-20-2009, 01:15 PM
  5. IS this just incredible or what????!!!!
    By Water4fire in forum 4-Tec Performance
    Replies: 25
    Last Post: 01-22-2006, 08:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •