Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    Zoo Keeper's Avatar
    Join Date
    Jul 2011
    Location
    Orange County, NY
    Posts
    33

    Question 2011 rxt is problem???

    I picked up a 2011 RXT IS and within the first hour the maintenece light came on. I checked what I can see and all seemed normal. I continued to ride with the light on and for about a half hour. Crusing at about 30-35 mph and power cuts down. The check engine light comes on along with the IBR light. WTF! I stop and have no neutral function and no reverse. I shut down the ski and restart, same result. I head back to the dock and as I approach I cut off the motor. I had to restart to position myself when I noticed the lights when off except the maintenece light. I had the reverse and neutral function and the IBR seemed to work. I bring it back to the dealer and I was told that on these skis sometimes the maintenece light comes on within the first hour and it just needed to be reset. I asked about the check engine and ibr and they did not find anything wrong.

    Has this happened to anyone? Normal? Anything? Please.


  2. #2
    HORSEPOWER JUNKIE 9secZO6's Avatar
    Join Date
    Jun 2007
    Location
    Belle Chasse, La.
    Posts
    2,006
    +1
    1
    Mine was on within 15min and the only code I could pull was a DESS code, 1656 or 1658 I think, and I did have intermittent issues with the yellow lanyard. I suspect it is bad, u however seemed to have somthing else going on. At least there is now a record with your dealer about the problem. And, this thread to determine if this is going to be issues with others.

  3. #3
    Zoo Keeper's Avatar
    Join Date
    Jul 2011
    Location
    Orange County, NY
    Posts
    33
    Quote Originally Posted by 9secZO6 View Post
    Mine was on within 15min and the only code I could pull was a DESS code, 1656 or 1658 I think, and I did have intermittent issues with the yellow lanyard. I suspect it is bad, u however seemed to have somthing else going on. At least there is now a record with your dealer about the problem. And, this thread to determine if this is going to be issues with others.
    Thanks, hopefully!

  4. #4

    Join Date
    Jul 2007
    Location
    hawkesbury ontario
    Posts
    127
    anybody else having trouble with lanyard? mine sucks have to really ruff to get it to beep twice

  5. #5
    Zoo Keeper's Avatar
    Join Date
    Jul 2011
    Location
    Orange County, NY
    Posts
    33
    Yeah it seems like you have to work it a little to much but mine never popped off.

  6. #6

    Join Date
    Sep 2010
    Location
    South Florida
    Posts
    1,599
    +1
    123
    Quote Originally Posted by Zoo Keeper View Post
    I picked up a 2011 RXT IS and within the first hour the maintenece light came on. I checked what I can see and all seemed normal. I continued to ride with the light on and for about a half hour. Crusing at about 30-35 mph and power cuts down. The check engine light comes on along with the IBR light. WTF! I stop and have no neutral function and no reverse. I shut down the ski and restart, same result. I head back to the dock and as I approach I cut off the motor. I had to restart to position myself when I noticed the lights when off except the maintenece light. I had the reverse and neutral function and the IBR seemed to work. I bring it back to the dealer and I was told that on these skis sometimes the maintenece light comes on within the first hour and it just needed to be reset. I asked about the check engine and ibr and they did not find anything wrong.

    Has this happened to anyone? Normal? Anything? Please.
    I have a 2010 RXTX. Within 5 minutes my S/C blew off and I went into limp mode. A few other crazy issues. No worries your not alone. These new skis seem to have some Gremlins... Find a good water tech and I mean a GOOD water tech in your area. After a few corrections the skis seem to settle down. Mine has not had and additional issues and I have 80+ hours. A few relatively simple mods and these skis seem to fly. Good luck...

  7. #7
    Zoo Keeper's Avatar
    Join Date
    Jul 2011
    Location
    Orange County, NY
    Posts
    33
    Quote Originally Posted by Glade Rider View Post
    I have a 2010 RXTX. Within 5 minutes my S/C blew off and I went into limp mode. A few other crazy issues. No worries your not alone. These new skis seem to have some Gremlins... Find a good water tech and I mean a GOOD water tech in your area. After a few corrections the skis seem to settle down. Mine has not had and additional issues and I have 80+ hours. A few relatively simple mods and these skis seem to fly. Good luck...
    Thanks for the info. Hopefully it won't happen again.

  8. #8
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    Like Glade Rider said... be patient and get the gremlins worked out. There was a BUDS update for the 2010's that re-calibrated the posts/keys.
    Also check the connection under your cluster - may be the iBR issue.
    Check the hose connections regularly and the pump support bolts are tight. You'll get used to it and LOVE the ski eventually!!!!!

  9. #9
    Zoo Keeper's Avatar
    Join Date
    Jul 2011
    Location
    Orange County, NY
    Posts
    33
    Cool thanks. She has some making up to me before I can LOVE her.

  10. #10
    DJKINN13's Avatar
    Join Date
    Jul 2011
    Location
    Winchester Va.
    Posts
    6
    Try red locktite on pump bolt has worked great,blue heats up and will come loose

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question regarding Maintenence light and IBR ssue on an 2011 RXT IS
    By Zoo Keeper in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 12-01-2017, 09:18 PM
  2. 2011 rxt is engine code P1661?
    By wakejumper48 in forum 4-Tec Performance
    Replies: 8
    Last Post: 12-01-2017, 09:16 PM
  3. 2009 RXT-IS or 2011 RXT-IS
    By BEECHFRONT in forum 4-Tec Performance
    Replies: 9
    Last Post: 04-09-2014, 08:10 PM
  4. 2011 RXT iS first ride
    By gentletiger in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 06-10-2011, 02:28 PM
  5. Just bought a 2011 RXT is 260
    By gbest in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 03-08-2011, 02:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •