Results 1 to 3 of 3
  1. #1

    Rpm issues on stock 2010 RXTX

    Hey guys i had a 2010 RXTX last year that ran great no issues at all exept the supercharger hose blowing off after 10 hours.

    With perfect conditions i saw 70-71 mph on the speedo( i live in Norway)

    I sold it this spring with only 25hrs on it going to an RXTX As but now i got a call from the new owner and he is telling me he is not getting the speed and rpms he should and have not done so since he got it.

    The ski only pulls 7700-7750rpm and maxes out at 65mph

    Any suggestions to whats causing this?

    Regards
    Ola


  2. #2
    eric1238's Avatar
    Join Date
    Jun 2005
    Location
    Smith Mtn. Lake VA
    Posts
    728
    +1
    2
    Check all the hoses again and check the pump bolts.

  3. #3
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    Boost leak...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Thinking of putting a new exhaust on my 2010 rxtx 260
    By Dion in forum 4-Tec Performance
    Replies: 15
    Last Post: 05-06-2015, 01:44 PM
  2. CODE ~ PO127 on a 2010 RXTX
    By stuckmoto in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-27-2012, 11:31 AM
  3. rpm for wide open throttle on stock sts750?
    By Texwing in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 08-15-2009, 04:19 PM
  4. RPM issues on new Speedster 430
    By TedC in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 05-26-2008, 09:06 PM
  5. Max RPM's on stock '07 RXP/RXT
    By ramnj in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-08-2007, 09:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •