Results 1 to 9 of 9
  1. #1

    Should engine turn over if start/stop switch pluds disconnected

    Hi all

    Have had a probelm with my ski. my question is this...

    Should engine turn over if start/stop switch pluds disconnected?

    Mine is, so I have to keep the battery leads removed, so any idea what the problem is?


  2. #2
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,326
    +1
    49
    Im confused are you saying when you connect the battery wire the ski starts turning the motor even when the wires from the start stop switch are disconnected there a 2 plugs coming from the switches. if it is spinning the motor when you connect the battery with both plugs unplugged you probably have a starter relay problem.

  3. #3
    leejax01's Avatar
    Join Date
    Apr 2011
    Location
    Jacksonville
    Posts
    1,161
    +1
    98
    Mine did it when the battery voltage was low and I kept on trying to start it. I would make sure the battery voltage is where it should when fully charged and then try the starter selenoid. After that it worked fine in my case.

  4. #4
    Quote Originally Posted by mudslanger View Post
    Im confused are you saying when you connect the battery wire the ski starts turning the motor even when the wires from the start stop switch are disconnected there a 2 plugs coming from the switches. if it is spinning the motor when you connect the battery with both plugs unplugged you probably have a starter relay problem.

    Yes thats exactly what I am saying, I have carried out a continuity test on the Starter Relay as per the workshop manual and the results are as follows:

    1. Check that there is continuity between the starter relay terminals. = No continuity
    2. Check that there is no continuity after the brown or black lead is removed. = No continuity

    So I assume the starter relay has remained open. If there is a fix then that would be great, but I get the impression Ill need a new one...

  5. #5
    Quote Originally Posted by leejax01 View Post
    Mine did it when the battery voltage was low and I kept on trying to start it. I would make sure the battery voltage is where it should when fully charged and then try the starter selenoid. After that it worked fine in my case.
    Yes thats what happened to me, i continued to try and start it when the volts got low, so i expected the starter relay has remained open.

    I have recharged the battery but still the same issue.

  6. #6
    Quote Originally Posted by mudslanger View Post
    Im confused are you saying when you connect the battery wire the ski starts turning the motor even when the wires from the start stop switch are disconnected there a 2 plugs coming from the switches. if it is spinning the motor when you connect the battery with both plugs unplugged you probably have a starter relay problem.
    Well I have now replaced the starter relay and still have the same problem, so it was not that after all.

  7. #7
    GoFastGuru's Avatar
    Join Date
    Jul 2010
    Location
    guntersville Ala
    Posts
    336
    +1
    8
    as mudslinger said put in a new relay

  8. #8
    GoFastGuru's Avatar
    Join Date
    Jul 2010
    Location
    guntersville Ala
    Posts
    336
    +1
    8
    check start stop circuit on handle bars something is wierd you have a bad new relay just a thought..are the wire going to box on thr hot side of relay not the black plug that is the kill side and look for cut in wire if these wires touch togeter it will roll over like holding the start button down

  9. #9
    An update. Put in a new relay and all is ok. Dont know what it was as the other relay still shows continuity between the starter relay terminals.

    My only issue to evercome now is the Trolling adjustment screw. Does not want to turn freely and the engine is running a bit fast after war up. Keeps springing back if you get my explaination. Seems to me like a spring or something is caught and it looks a bit of a mare to see completly.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB: Sea Doo SP (95') Start Stop Switch ASAP
    By Hybrid AWD in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 08-28-2012, 09:00 AM
  2. GPRXP Start/Stop switch modification
    By Hydrotoys in forum Conversion FAQ and Tips
    Replies: 28
    Last Post: 10-13-2010, 05:06 PM
  3. should engine turn over with no CDI
    By Slipknotanfitch9 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-22-2010, 05:27 PM
  4. Replies: 1
    Last Post: 04-02-2010, 09:41 AM
  5. Engine turns over but won't iddle
    By exodo90 in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 07-15-2007, 12:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •