Results 1 to 5 of 5
  1. #1
    vrdarr's Avatar
    Join Date
    Aug 2009
    Location
    Galveston
    Posts
    4

    2000 Polaris Virage TX Stalling Hesitating at WOT

    I have a 2000 Polaris Virage TX. At WOT it will drop a cylinder or two, but keep running. I can get off of the gas and get right back on it, and then it fires on all 3 again. It used to happen once a outing and it's gotten worse over the year to more than a dozen times a outing. I searched the forums but I didn't find this problem. I've had this ski for about 7 years and it's always run strong. Do you have any recommendation what I should replace/rebuild first? THANKS!


  2. #2

    Join Date
    Jul 2011
    Location
    Lake of the Ozarks
    Posts
    46
    It sounds more like spark to me but you cant take a chance on fuel.
    Trim back the plug wires and make sure you have good plugs. If that doesnt clear it up go through the carbs ,lines, filters, and fuel pump. If you've not done that in 7 years I would do the fuel system anyway.

  3. #3
    vrdarr's Avatar
    Join Date
    Aug 2009
    Location
    Galveston
    Posts
    4
    Thank you. I just pulled the carbs and the inlet fuel line is nice and green inside. So I guess I'll start with fuel lines and carb kits. Ill check the plug wires too; I have new plugs. Thanks for the advice. The only thing I've changed in the past is a bad voltage regulator. Any easy performance ugrades I should consider while it's semi-apart? I've only had one other ski ever beat me, and it was just barely.

  4. #4

    Dont get burned like i did

    Quote Originally Posted by vrdarr View Post
    Thank you. I just pulled the carbs and the inlet fuel line is nice and green inside. So I guess I'll start with fuel lines and carb kits. Ill check the plug wires too; I have new plugs. Thanks for the advice. The only thing I've changed in the past is a bad voltage regulator. Any easy performance ugrades I should consider while it's semi-apart? I've only had one other ski ever beat me, and it was just barely.
    I spent $1000 on the same issue on my 2000 Genesis and still did not fix it. The tech replaced CD I, coils, and rebuilt carbs.
    It ended up being a $60 part. The rubber exhaust tube seperated internally, causing a restriction. It would idle fine, wot would fall on face. Replaced tube and worked great!

  5. #5
    What rubber tube are you reffering to? do you have a part number i can referance back to? im working on a friends pwc and am running into same problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 polaris virage tx resonator melted.
    By gnose in forum Polaris Open Discussion
    Replies: 10
    Last Post: 08-25-2017, 12:02 PM
  2. Buying a 2000 Polaris Virage TX
    By 785xp in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-14-2011, 08:15 PM
  3. FS Non-running 2000 Polaris Virage TX ( Houston, TX )
    By thehemi in forum Polaris Classifieds
    Replies: 19
    Last Post: 04-23-2011, 03:35 AM
  4. 2001 Polaris Virage TX Bogs Down at 2000-3000rpm
    By frewworld in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-30-2009, 09:37 PM
  5. 2000 Polaris Virage TX Help!
    By paperbirch in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-27-2007, 12:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •