Results 1 to 6 of 6
  1. #1
    JD jdy2kgt's Avatar
    Join Date
    Jun 2009
    Location
    VA
    Posts
    30

    900 STS won't go above 34MPH

    I purchased a 900 Sts ski and had it checked by my mechanic who had told me everything was fine. When I finally took it out it ran great except it won't go above 34 MPH. The ski feels fine likes it not knocking or smoking or feeling like its going to stall. I took for a 2 hr ride with no problems at all, except it maxes out at 34MPH. My 96 STX had a screw by the throttle that you could for newer riders so they couldn't go as fast. Is there anything like that on this ski that might be causing it to be in a learning mode?

    Thank you,
    Jim


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,011
    +1
    283
    Well, it would be real easy to pull the throttle trigger and take a look, wouldn't it?

    You might also have a cylinder that's not firing.

  3. #3
    Hey I just bought the same ski,also professionally inspected on land only unfortunately.Exact same problem.
    Did you ever come up with a solution?Seems like it has to be firing on just 2 cylinders.Compression is def good on all 3.
    I am going to check for spark on all 3 plugs but it's too early right now,family is sleeping!

  4. #4
    Ok a little follow up.I actually figured out that the middle cylinder wasn't getting any spark.I thought I was "the man" for a little while anyway.I opened the box that houses the coils and ignitor and cleaned the heck out of all the electrical connections and bam-spark to all 3.Headed out to the lake where she ran like a beast-for 10 minutes and then totally died.Now I have NO spark at all!
    My question is does anyone know where to get shop manuals for a 2001 900 STS?I can't come up with anything on Google.Is there a manual for another model that applies?I want to be able to troubleshoot this correctly before dropping the 400+ on the ignitor.
    Thanks,VC

  5. #5
    please stick to your post.

  6. #6
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,011
    +1
    283
    Sounds like you have a bad ground connection or something.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 900 STS won't go over 36 mph
    By chiadrum in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-06-2012, 07:39 AM
  2. 2000 XL limited won't go above idle
    By dalepatter in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 09-06-2011, 02:01 PM
  3. VX110 Deluxe Won't go above 35 mph and 6000 rpm
    By Yimihemi1200 in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 07-26-2011, 08:59 PM
  4. 07 RXT won't go above 5600 rpms....need help
    By Fatty in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-16-2010, 11:43 PM
  5. 97 900 ZXI won't go over 5000 RPMs
    By uwbadgers in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-25-2010, 04:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •