Results 1 to 6 of 6

Thread: Water In Hull

  1. #1

    Water In Hull

    1994 Polaris SL750

    Ok Iíve been on a 6 month journey to get this thing running again and I can see light at the end of the tunnel, It now has a new motor, v-force reeds, engine aligned, rebuilt carbs and gallons of my sweat and blood in it. last problem is WATER IN THE HULL. Went out yesterday blew out my siphon lines before we went out, ran about 30 mins... not much water ran another 30 mins... about an inch in it, looked after an hour and it was almost up to the top of the driveshaft. got it out pulled the drain plug and it looked like I was trying to take the lake with me. Iíve filled it up and it didnít show any leaks, and the through hull being is full of grease and the engine is lined up.


  2. #2
    I'D RATHER SWEAT THAN SHIVER hyoctane23's Avatar
    Join Date
    May 2007
    Posts
    1,976
    +1
    34
    Check your pitot tube for your speedometer connection right under the drive shaft seal. That tube might have popped off.

  3. #3
    Yup checked it not cracked or dissconnected.... I was hoping it would be that easy

  4. #4
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    check your water rail on top of the heads as you run the engine in the water. the small water rail gaskets could be leaking spraying water and filling the hull when you take it out. and filling the hull with water, it wont show the leak because theres no pressure on the gaskets or rail , you would only see the leak if it was running and that would fill the hull as you ride. I had it happen to me on my sl750. the rail was warped a lil and it didn't seal good with the gaskets on it so I doubled them up and it worked out ok.. should get a new non warped water rail to really fix it though..

  5. #5
    I'D RATHER SWEAT THAN SHIVER hyoctane23's Avatar
    Join Date
    May 2007
    Posts
    1,976
    +1
    34
    Yeah, I was going to say run it with the seat off and see if there is any water spraying in somewhere.

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Quote Originally Posted by hyoctane23 View Post
    Yeah, I was going to say run it with the seat off and see if there is any water spraying in somewhere.
    X2

    Might be coming in the thru hull, but only when the engine is running.

    Also the water inlet hose sometimes wears a hole near the front of the exh pipe.

    Could also be coming in from the trim motor if the gasket is shot.

    Run it on the trailer at the ramp.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rxp cavitating badly, water in hull
    By kenshin89 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-21-2006, 12:13 AM
  2. Water in hull up to engine cover
    By jonstephens in forum 4-Tec Performance
    Replies: 20
    Last Post: 09-25-2005, 12:56 AM
  3. Water in Hull
    By UFO-RXT in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-21-2005, 06:40 PM
  4. Alot of water in hull
    By Drake in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-26-2005, 07:42 PM
  5. RXP Water in Hull
    By jpwt62 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-06-2005, 10:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •