Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    Question Need in put. Help

    HI . We have a RXP 05.

    It run,s good, But ? When you start to play around on it, and flip it around. The heat lite come on and it buzz. As soon as you stop doing this . It go,s off and it fine.
    NEED HELP.

    LEFT COAST GIRL.:-


  2. #2
    suck my wake's Avatar
    Join Date
    Apr 2006
    Location
    Sugar Grove IL
    Posts
    2,872
    +1
    12
    Make sure none of your hoses are clogged, sounds like your not getting enough water into the waterbox so the sensor is getting too hot.

  3. #3
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Check the coolant level

  4. #4
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    If everything checks out OK, it could be what you are doing ... these skis do not like being slid and thrown around ... most of them will throw that alarm if you treat them like an old two stroke and spin them and toss them around. Too many sensors, and cooling is more sensitive on the high hp four strokes, they are not meant for endless spinnies.

  5. #5
    Always been able to do this . So that is not it. I have check the hoses all are ok. maybe my SC is clogged ?

  6. #6
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    SUPERCHARGER clogged!! ,....yea check that

  7. #7
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    ha ha ha

  8. #8
    Why would someone say ha ha ha? Do you fined it,s funny when someone ask for help.?
    If you have nothing to Aid that is helpful. Then don't open your mouth.
    And Thank you for all of your help on this site.
    Left Coast Girl.

  9. #9
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    So, it just recently started to overheat when you spin it around?
    Try back flushing the ski, you may have some debris clogging the open loop part of the cooling system.

  10. #10
    Yes it just stared doing this.
    left coast girl.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help/Info needed in Paducha, KY
    By 83Gator in forum Open Discussion
    Replies: 3
    Last Post: 12-04-2009, 05:33 PM
  2. Help, 93' SL750 need to put oil in crank before startup???
    By dubstylguy in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 07-28-2008, 10:16 AM
  3. D Boost Help Needed In Wiring
    By ridem32 in forum Honda Open Discussion
    Replies: 14
    Last Post: 07-25-2008, 12:49 AM
  4. Need some job help in San Antonio, TX!
    By Yellow93 in forum Open Discussion
    Replies: 5
    Last Post: 10-06-2007, 11:45 AM
  5. Forum Member In Need Of Your Help!!!
    By gtxscrider in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-13-2007, 08:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •