Results 1 to 4 of 4
  1. #1
    immred's Avatar
    Join Date
    Jul 2007
    Location
    Manassas VA
    Posts
    154
    +1
    1

    2010 RXT-X260 Bad Support Plate Formed Seals

    Click image for larger version. 

Name:	Right Side Seal .jpg 
Views:	60 
Size:	48.3 KB 
ID:	247296Click image for larger version. 

Name:	Left Side Seal2.jpg 
Views:	58 
Size:	68.3 KB 
ID:	247297Click image for larger version. 

Name:	Left Side Seal1.jpg 
Views:	65 
Size:	73.1 KB 
ID:	247295
    My ski (with 47 Hrs)was taking on more water than I though it should. I noticed the top formed seal on the right side by the IBR was split. Took it all apart. On the leaft side (IBR) 4 of the 6 seals were split. On the right side 1 of the 3 was split.


  2. #2
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,849
    +1
    742
    see my thread page 109 post 1084 same subject

    http://www.greenhulk.net/forums/show...ments!/page109

    The plate I made for the right side is working flawlessly! The left side would be very difficult to fabricate since it has inserts facing BOTH directions.

    Not only is this a sealing/leak issue, it is also a brass insert in plastic stripping out problem. VERY POOR DESIGN!!

  3. #3
    Full Throttle or Broke!!! UNSANE's Avatar
    Join Date
    Aug 2008
    Location
    Orlando
    Posts
    721
    +1
    82
    Quote Originally Posted by immred View Post
    Click image for larger version. 

Name:	Right Side Seal .jpg 
Views:	60 
Size:	48.3 KB 
ID:	247296Click image for larger version. 

Name:	Left Side Seal2.jpg 
Views:	58 
Size:	68.3 KB 
ID:	247297Click image for larger version. 

Name:	Left Side Seal1.jpg 
Views:	65 
Size:	73.1 KB 
ID:	247295
    My ski (with 47 Hrs)was taking on more water than I though it should. I noticed the top formed seal on the right side by the IBR was split. Took it all apart. On the leaft side (IBR) 4 of the 6 seals were split. On the right side 1 of the 3 was split.
    Had the very same issue with my iS on the left side. I wasn't leaking that bad, but I still had the issue addressed under warranty and will keep an eye on it...especially since I ride in salt on occasion.

  4. #4
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    Hmmm...I ordered the fixing plates for back-up. I guess I should order the seals too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 rxt-x260 O.T.A.S code
    By RXT-X300 in forum 4-Tec Performance
    Replies: 48
    Last Post: 05-11-2015, 08:08 AM
  2. Carbon ring problem? -2010 RXT-X260, 42 hrs.
    By immred in forum 4-Tec Performance
    Replies: 14
    Last Post: 09-17-2011, 01:02 PM
  3. I need help with BUDS - 2010 RXT-X260
    By immred in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-13-2011, 12:46 PM
  4. 2010 RXT-X260 4" Fizzle intake. Hose placement!
    By nlpnrxt1 in forum 4-Tec Performance
    Replies: 7
    Last Post: 09-26-2010, 11:28 AM
  5. Hi ! New member with ??? about 2010 RXT X260
    By Patrick917 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 03-23-2010, 11:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •