Results 1 to 2 of 2
  1. #1

    Exhaust rattle at low rpm's

    Anybody else have this problem on their Ultra, goes away when I,m going?


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,006
    +1
    281
    You probably need to replace the bearings. They don't last very long on the Ultra. Don't know what year you have, but make sure they put the extra seal in the pump when they work on it.

    Some noise, or ringing, is normal when running on the trailer.

    Oops! I just noticed that you said the EXHAUST was rattling. Never heard of that.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 08-08-2010, 01:40 PM
  2. 99 SLTH - Top End Runs great, bogs down at low RPM
    By thiagoavila in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-29-2010, 12:02 PM
  3. fx160 2006, wont run properly at low rpm's
    By Turbo Retro in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 02-01-2010, 05:19 AM
  4. Exhaust Alarm and Low RPM's
    By NJRXP in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-09-2007, 06:17 PM
  5. bogs down at low rpms
    By RiverRat19405 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-01-2007, 06:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •