Results 1 to 5 of 5

Thread: coolant system

  1. #1

    Join Date
    Jul 2011
    Location
    Tampa Bay, FL
    Posts
    51

    coolant system

    Was out on ski today and high temp alarm came on. Anyways got back in and checked it over and in the Hull I found a bolt and some broken clamp looking metal. So it must be a clamp that broke on the cooling system. My question is where are the cooling lines that have clamps? Trying to save money by doing it myself. Thanks!


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Cooling system clamps are all over the place.

  3. #3
    Sounds like my day last week. Cruisin along in my sportster 215 scic and temp light/beep came on. Shut her down and opened up the engine compartment to find the main coolant hose off the head had popped off, spewing out all my coolant. Stock oetiker clamp still intact on the hose too, POS! Easy fix for me, but as mentioned, several places could be the culprit in your case. Just look around.

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    What I usually do is go to the OE replacement part section at the top of the page and find your year and pull up the cooling system diagram. That should show you all the clamps.

  5. #5

    Join Date
    Jul 2011
    Location
    Tampa Bay, FL
    Posts
    51
    Alright ill check that out. Thanks guys for the quick response

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 11-19-2015, 02:02 PM
  2. How-To: Coolant Change
    By MikeTrin in forum Sea Doo How To & FAQs
    Replies: 65
    Last Post: 07-24-2012, 11:16 AM
  3. just dying to hear some numbers on that 300hp fuel system.
    By theantiRXP in forum 4-Tec Performance
    Replies: 16
    Last Post: 01-14-2012, 11:16 PM
  4. Help with coolant system
    By 03gtx in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-27-2011, 05:31 PM
  5. Pictures of Rotax Racing's new 300 HP system
    By Green Hulk in forum 4-Tec Performance
    Replies: 32
    Last Post: 05-12-2005, 08:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •