Results 1 to 2 of 2
  1. #1

    2005 Seadoo Wake Edition Mid throttle Miss

    103 hrs Plugs changed during winter service. Ran good until this weekend. Cranks fine. Idles fine. Wide open fine. 7300 no missing.
    When cruising between 4500 and 5500 engine will drop 400 to 500 rpm for about 2 seconds and then pick back up.. Surging. Have already changed plugs two times with new. Inspected coil packs and connectors during plug change. Nothing I could see there. No split boots or any evidence of spark arcing. It is also showing no error codes...

    Coil pack going bad????


  2. #2
    mrbtd's Avatar
    Join Date
    Jul 2005
    Lindenhurst, Illinois, United States
    most likely

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 Seadoo Wake - Gelcoat Restoration - Before and After Pics - REBORN!!!
    By YoCoLifSavr in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 06-17-2011, 12:04 AM
  2. 2005 Seadoo Wake (NY Metro)
    By WinniCandle in forum Sea Doo 4Tec Skis
    Replies: 2
    Last Post: 09-07-2008, 07:20 PM
  3. 2005 Wake Edition with 215HP?
    By Bill 3 in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-13-2007, 07:18 PM
  4. HELP First Mods for '07 SD Wake Edition
    By Fly'n Dutchman in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-01-2007, 03:29 PM
  5. 2005 Seadoo wake
    By wateranimal in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 04-26-2006, 07:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts