Results 1 to 4 of 4
  1. #1
    NJ -> MD Jet ski trip fuel mileage champ carguy89's Avatar
    Join Date
    May 2011
    Location
    NJ
    Posts
    858
    +1
    33

    FX140 not going above 10 mph

    My friend has an FX140 with about 60 hours. Last weekend he lost oil from a rotted oil filter. No warning light came on, he shut it off on his own, no problems ran fine. He took it to a mechanic and cleaned bilge, replaced oil and filter. Ran good on land, revs up, etc. Water tested it and can only get it to 10 mph. It seems like it wants to go more but something is holding it back. Tried resetting ECU, cleaned connections that could've gotten oil soaked, nothing worked.

    Disconnected battery to reset ECU, no different. Revs up fast then quickly drops to 6k rpm. Won't go past 10 mph or 7k rpm still.

    He disconnected all plugs around the fuel rail that looked oil soaked and cleaned, no different. Mechanic replaced plugs and air filter as well.


  2. #2
    NJ -> MD Jet ski trip fuel mileage champ carguy89's Avatar
    Join Date
    May 2011
    Location
    NJ
    Posts
    858
    +1
    33
    Update: he sprayed carb cleaner in the MAF and now it'll do like 35 but still not right

  3. #3
    NJ -> MD Jet ski trip fuel mileage champ carguy89's Avatar
    Join Date
    May 2011
    Location
    NJ
    Posts
    858
    +1
    33
    TPS issue maybe? Ran it without air cleaner and seems like it's still not getting enough air. Seems to get plenty of fuel

  4. #4
    NJ -> MD Jet ski trip fuel mileage champ carguy89's Avatar
    Join Date
    May 2011
    Location
    NJ
    Posts
    858
    +1
    33
    Quote Originally Posted by carguy89 View Post
    TPS issue maybe? Ran it without air cleaner and seems like it's still not getting enough air. Seems to get plenty of fuel

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rxt 215 will not go over 35 mph
    By Dhenry6149 in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 07-04-2014, 12:55 AM
  2. Ultra-150 will not go past 5-mph
    By Nohype! in forum Kawasaki PWC Performance (2-stroke)
    Replies: 18
    Last Post: 06-24-2013, 11:07 AM
  3. LRV DI 2001 not going above idle
    By MattAus in forum 2-Stroke Performance
    Replies: 5
    Last Post: 06-18-2013, 05:38 AM
  4. 2002 virage I starts but rpm will not go above 1000
    By whatspoppinn in forum Polaris Open Discussion
    Replies: 2
    Last Post: 03-21-2012, 05:57 PM
  5. VX110 Deluxe Won't go above 35 mph and 6000 rpm
    By Yimihemi1200 in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 07-26-2011, 08:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •