Results 1 to 8 of 8
  1. #1

    2004 rxp oil light

    The other day I was on my ski and the oil light came on and it ran real bad, you pull the key and it would start right up and idle good, if you went anymore then 3000 rpm the light would come on and it would run really bad. I guess it goes into limp mode. Oil level is good. I think I read there was 2 oil sensors on these 4 tec engines. Could one of them be going bad. If I start it up now, it idles and revs fine out of the water, have not put it back in the water to test yet. Is there an ohm test I can do on the sensors or anything else it might be? I hooked it up to my scanner and had no stored codes.

    Thanks,
    Jessie00721


  2. #2
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    What code(s) is the ski throwing?

  3. #3
    I had one for wrong key and tps but they were not at the time of the problem, no codes are currently popping up.

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Check your oil pressure the sensors are there for a reason. Once you verified oil pressure is within spec then look into the sensor.

  5. #5
    ok, found the info in the manual. I dig up a pressure gauge and check, if that is ok, I will ohm test the sensor iaw the manual. thx

  6. #6
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    That should be a good starting point.

  7. #7
    Well it’s been quite some time but finally got a new oil pressure sensor and problem solved. It was the sensor under the throttle body. Did have a small issue with the #2 coil not firing but replacing it did correct the problem. Have some cosmetic issues with the front hatch and missing a sponson but still managed around 60 mph in rough water. Need to fix the cosmetics and try it on a calm day now. No engine codes and finally no limp mode.....!

  8. #8
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Thanks for the update.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 Seadoo RXP Oil Light
    By Thrifty in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 06-15-2015, 05:38 PM
  2. 2004 RXP oil in hull?
    By pappysseadoo in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-12-2013, 07:27 PM
  3. 2004 rxp oil leaking out of exhaust
    By islandracer in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-16-2010, 08:21 PM
  4. FS 2004 rxp oil separator +
    By 8 is enough in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 09-29-2009, 07:47 PM
  5. Rxp Oil Light??
    By gav1n in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-02-2009, 05:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •