Results 1 to 2 of 2
  1. #1
    Ahh....where am I?
    Join Date
    Jul 2006
    Baywood - Brick, NJ

    OPAS Dragging, Help! Just the Starboard

    So, the right/starboard OPAS was broken off my '05 GTX Limited. Only needed to order 2 plastic pieces. We reassembled the OPAS.

    Now, the right OPAS drags, most of the time. Didn't have my GPS on, but the dream-o-meter would only read 54mph, and I was shooting up a "neat" rooster-tale. It looked cool, but It felt like I was dragging an anchor. And I'm all about going fast, so it's a total drag. lol.

    I'm going to try to have a look at it at full speed, and hang off the back to see what's going on. But in the meantime, are there any known issues with these things? I know most people remove them, but I think for some of my family members need all the help they can get. If I can't see what's going on, I'm going to PVC pipe them into the up possition.


  2. #2
    MSRXP's Avatar
    Join Date
    Sep 2010
    Central MS
    Take em off. You will feel like you lost 100 lbs off the back. Block offs are 90.00.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 Speedster - Starboard engine will not start
    By jcostello56 in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 04-12-2011, 10:27 AM
  2. Dragging
    By meirvin in forum Mudbug Nationals PWC.Life Rally
    Replies: 2
    Last Post: 06-05-2009, 12:19 PM
  3. SC Washers, Low RPM Starboard?
    By beezer in forum Sea Doo Sport Boats
    Replies: 13
    Last Post: 04-16-2008, 09:41 PM
  4. Bent my starboard 15/20R
    By somefun in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 06-30-2007, 07:05 AM
  5. Port or Starboard ?
    By WFO in forum Yamaha Open Discussion
    Replies: 29
    Last Post: 01-25-2007, 11:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts