Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    2005 kawasaki 900stx ignition issue

    im not getting spark to any of the cylinders. any info maybe bad igniter or something?


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Does the starter crank the engine? Does the display light up when you turn on the switch?

  3. #3
    yes it turns over fine just doesnt have ignition spark. yes the display works

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Don't know. How did you check for spark? Are the plugs wet?

  5. #5
    with a inline spark tester that has a light built in and then double checked with a screwdriver

  6. #6
    I usually set the end of the plug against the top of the hole and then look for spark at the node. Sometimes I find the screw driver method doesn't always work, but whatever works best for you. It's just what I find to be reliable.

    Did you check for compression. If you take the spark plug out and put your finger over the hole, the motor should easily blow it off if you crank it over. Be sure to disconnect the spark plugs when testing.

    Check all your wiring connectors and make sure they have good connection and are not corroded. If you find any that are corroded, scrape it off with a screw driver or similar and put some grease on the metal before reconnecting. I know on my ski, everything in the electrical wiring has to be connected or it will not run, including the trim box, etc.

  7. #7
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    I prefer to test with a known good spark plug. Hard to see in bright sunlight, too.

  8. #8
    has good comp, just no spark

  9. #9
    ya i use a spark tester that has a light built in that lights up from the voltage. and i use a snap on compression tester. it doesnt have spark.
    the question im after is why not? Not does it or not. just looking for a common problem stator signal, igniter etc.. and how to test each for voltage or ohms or either or

  10. #10
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Sounds like you need a service manual. That would have the test procedure for the stator and the ignitor.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB 2005 900stx igniter wanted
    By sr240 in forum Kawasaki Skis
    Replies: 0
    Last Post: 08-03-2011, 03:02 PM
  2. Ph2ocraft, Anyone, Help!!! 780 ignition issues!!
    By JGringo in forum Polaris PWC Performance
    Replies: 4
    Last Post: 05-21-2008, 12:30 PM
  3. Kawasaki 900stx spark plug?
    By Bala in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-09-2008, 11:57 AM
  4. F.S. 2005 Kawasaki STX-15F Like New
    By 04tacoma4x4 in forum Kawasaki Classifieds
    Replies: 9
    Last Post: 04-26-2008, 10:17 PM
  5. Kawasaki 900STX
    By PhilnEdee in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-28-2007, 08:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •