Results 1 to 5 of 5
  1. #1

    Help my jetpump is stuck on hull... Howto remove? 1993 XP

    Hello i have a 1993 Seadoo XP (5852) whit 657 engine.

    I think the splines on the driveshaft / pto flywheel are stripped.

    If the pump / engine alignment is bad can it strip down your splines?

    Now i have taken of the steering & VTS cables and the 3 hoses in the hull and the 4 17mm nuts that secure the pump to the hull , but there is a lot white of corrosion between the studs and the pumphousing.

    I have taken the venturi of and put 4 10 inch studs in the pumphousing , two pieces of 2x4 whit holes drilled into it are my puller , they are sitting against the back of the hull and i am tightening the 4 nuts on the studs that are coming trough the 2x4's

    But...

    A lot of force is put into this and the nuts where tight!! and the pump isnt comming of.

    Is there a trick ore something sow i can get the pump of my hull?

    Would tapping the rideshoe from the bottom whit a hammer help to break the corrosion lose?

    Can i get some stuff to desolve the silicone kit or something?

    The shaft isnt stuck into the pto flywheel and seal carrier because i had to take my engine out to replace the sealcarrier last week.

    Please help!!

    Thnx Mellos from The Netherlands (Thats why my english isnt 100%)


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,518
    +1
    1,266
    Quote Originally Posted by Mellosv6 View Post
    Hello i have a 1993 Seadoo XP (5852) whit 657 engine.

    I think the splines on the driveshaft / pto flywheel are stripped.<<<OUCH>>>

    If the pump / engine alignment is bad can it strip down your splines? <<<YES, So can Not greasing it regualr)>>>

    Now i have taken of the steering & VTS cables and the 3 hoses in the hull and the 4 17mm nuts that secure the pump to the hull , but there is a lot white of corrosion between the studs and the pumphousing.

    I have taken the venturi of and put 4 10 inch studs in the pumphousing , two pieces of 2x4 whit holes drilled into it are my puller , they are sitting against the back of the hull and i am tightening the 4 nuts on the studs that are coming trough the 2x4's

    But...

    A lot of force is put into this and the nuts where tight!! and the pump isnt comming of.

    Is there a trick ore something sow i can get the pump of my hull?<<<More force>>

    Would tapping the rideshoe from the bottom whit a hammer help to break the corrosion lose?<<light tapping won't hurt..don't break anything>>>

    Can i get some stuff to desolve the silicone kit or something?<<<you don't want to go there..if the last person to service the pump used the wrong sealer, you will have some problems getting the pump off..some folks have set thier puller on a chain and yanked the pump off with a truck>>

    The shaft isnt stuck into the pto flywheel and seal carrier because i had to take my engine out to replace the sealcarrier last week.<<well if you took the engine out, it will ikely not be in correct alignment after that, even if you tracked the shims, the motor mounts have enough play that you can cause problems with the driveshaft/pto. I've done a few PTO's on the 587 motors and the pumps can be tough to get off>>
    Please help!!

    Thnx Mellos from The Netherlands (Thats why my english isnt 100%)
    my comments in bold

  3. #3
    Joe Stang's Avatar
    Join Date
    Aug 2008
    Location
    Durham, CT
    Posts
    1,928
    +1
    61
    I have a slide hammer with a plate I made that bolts to the back of the pump itself, a few good hard pulls on it and it will pop of the old stuck pumps in no time!

  4. #4
    kecheme's Avatar
    Join Date
    Jul 2011
    Location
    Phoenix Az
    Posts
    208
    +1
    7
    +1 On the slide hammer. I use my automotive hub adaptor with 5lbs slide hammer. It works!

  5. #5
    Thanx guys!

    the problem wasn't the splines but a big waterplant whit some fishingwire blocking the jetpump intake. (Dumbass :P)

    But the seadoo is sold today

    The next one is a 2007 rxp whit a turbo bolted on & 255hp

    Thnx Mellos.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My Shaft is stuck- Help!!!
    By Pwgsx in forum 4-Tec Performance
    Replies: 20
    Last Post: 10-28-2013, 11:46 AM
  2. The removable tongue on my trailer is stuck
    By Tampa85 in forum Towing and Trailers
    Replies: 5
    Last Post: 04-01-2010, 08:50 AM
  3. Need Help! My Trim Is Killing Me
    By xanthras in forum Polaris Open Discussion
    Replies: 20
    Last Post: 08-18-2008, 11:15 AM
  4. My STX15F is finally on its way to OZ!
    By surfin in forum Kawasaki Open Discussion
    Replies: 12
    Last Post: 06-11-2008, 12:45 AM
  5. Help - I suspect my wife is cheating on me
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 12-02-2005, 04:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •