Results 1 to 8 of 8
  1. #1
    Kyle-71's Avatar
    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    17

    1997 GSX Carb issue. Please Help!

    Hey Guys. Yall helped me a while ago when I needed to change my fuel lines. I had just brought this thing to my local Sea-Doo dealership to have the carbs rebuilt. They assured me that the fuel lines were fine. I did not trust them so I changed them out after only about 1hr ride time on the machine. When I changed them the whole fuel system was rather clean. All was running great at the time. Now after about another 1hr ride time I started to notice a slight bog. Time to clean the carbs.

    The screen in the MAG carb was a little dirty, but not too bad. The PTO screen was plugged pretty bad.





    Cleaned them up good with carb cleaner..... Just like new, good to go.

    My question here is, why was this gasket missing from the PTO carb? It was there in the MAG side. I have rode this thing for approx. 2hrs like this with no problems. Did the dealership forget to put it in? Will riding it like this hurt it? It hasn't as of yet.







    My Wife expects to ride this thing for our anniversary VAC that starts in 2 days.

    Any help / advice yall!!!!


  2. #2

    Join Date
    Mar 2006
    Posts
    1,831
    +1
    119
    Bring it to me-- I can fix anything on your machine in time for your Vacation PM me.

  3. #3
    Kyle-71's Avatar
    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    17
    NK!!!! Thanks for the answer to my question.....



    I put it together and it is running OK on the trailer. I guess a water test will be my only answer.......

    Unless AirborneXP stops by. Thanks again for your help in the past man.
    Last edited by Kyle-71; 07-31-2011 at 12:50 PM.

  4. #4
    Kyle-71's Avatar
    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    17
    OK. Now I'm pretty sure you're just making fun of a newb. According to parts websites, This gasket does not exist. The MAG side gets one but the PTO does not.

    The gasket I'm talking about is #52 on this page.

    http://partsfinder.onlinemicrofiche....pe=13&A=46&B=8


    Maybe this should be a little more clear in the Manual.

  5. #5
    Kyle-71's Avatar
    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    17
    No one can confirm this for me?

    Guess I'll just try it. Going to the lake for a week. Hope it works!

  6. #6

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9
    1 fuel pump feeds both carb's -so it's not needed in carb with no fuel pump

  7. #7
    Kyle-71's Avatar
    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    17
    Thank you very much Chip for the reply. The machine ran good all week. Good to go for now!!!

  8. #8
    GoFastGuru's Avatar
    Join Date
    Jul 2010
    Location
    guntersville Ala
    Posts
    336
    +1
    8
    can having this gasket in the pto carb make it run bad

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 zxi1100 fuel carb issues please help
    By Hi burton in forum Kawasaki PWC Performance (2-stroke)
    Replies: 16
    Last Post: 08-13-2017, 04:57 PM
  2. 1997 STX 1100 electrical issues - please help
    By tcknapp in forum Kawasaki Projects
    Replies: 20
    Last Post: 11-14-2012, 08:42 PM
  3. powervalve issue. please help!
    By jeremy3477 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-21-2008, 07:34 PM
  4. gp1400r carb issues pleas help
    By gpr-sam in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 10-11-2007, 06:11 PM
  5. Carb Gurus Please Help
    By RaystownLake GPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 23
    Last Post: 07-07-2006, 08:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •