Results 1 to 4 of 4
  1. #1

    2000 GP760 Wont start...HELP

    Hey guys,
    new member, and first time jetski owner. Ive always tinkered with cars, motorcycles, and dirtbikes, but never a pwc. i just moved to the fl keys a month ago, and got a good deal on a jetski that needed some work. i figured its a task i handle. anyway, its a 2000 yamaha gp 760, and the guy before me disconnected the oil pump. he told me the last time he rode it, it wouldnt plane, so he took it in, and there it sat for a year... i bought it, battery was dead, tried firing it up, nothing..its cranking, but then i looked, its getting absolutely NO FUEL. theres a primer on the side(not a choke, like the manual says) and even if i prime it, theres no fuel even coming toward the primer thru the line..its as if nothings coming outta the fuel tank..i did notice that there was like NO gas in the tank, so i put like a gallon in there. what do you guys suggest? is the "fuel pump bad"? or is one gallon not enough to get the fuel pump wet so start a primed flow? i did take one side off of the fuel filter and put my finger over the hose, so the carbs ARE sucking for gas...any info you guys can provide would help.thanks!

  2. #2
    mudslanger's Avatar
    Join Date
    Jul 2010
    Huntsville Al
    Since the ski is on premix you need to mix the wright amount of oil to gas ratio in the tank. before you put anymore gas in the tank you should try to remove all the old gas. since you already put a gallon in it try shaking the ski to slosh the gas around so you can get as much of the old gas out as possible.
    Once you have cleaned the tank put about 5 gallons of premixed gas in the tank that way you can leave the cutoff in the ON position.
    The best way to crank one that has sit for a long time is to remove the plugs and put a small amount of premixed gas in the cylinders about a oil cap full then put plugs in and hold throttle open and try cranking the ski you may have to do this a few times. IF it doesn't pick up the fuel and keep running the carbs may need to be cleaned.

  3. #3
    Hey, thanks man... I actually called a guy last night and he told me i should pour a spoonfull of mixed gas down the carb where the flame screens are, then try crankin it. i did that, and it kinda fired up, like it sounded like it was going to, then i noticed there was some mixed gas leaking toward the front on the bottom of the hull, as if whatever i put in, leaked i said screw it and took the carbs off. took them all apart, and i have them soaking in gas right now. to be honest, that other guy told me i should buy a "carb rebuild kit", but after opening up the carbs, it doesnt look liike theres much to rebuild. the float pins arent sticking, and besides a tiny bit of buildup inside like where the screws go, they look clean..question: could the "leak" have been coming out if one of the screws (the one that looks like a little bar going thru it) is not tightened enough? also, so once the ski fires up, from putting gas in the cylinder head, and i put 5 gallons in the ski, this should be enough pressure to make the gas flow? cuz as i said earlier, there isnt even gas coming toward the primer inside the line when i prime it..

  4. #4

    Join Date
    Aug 2011
    goldsboro, nc
    I feel like I'm having the same problem; in order to my GP760 to start I have to spray premix through spark arrestors to get it to crank then after that it will idle by itself?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 yamaha gp760 wont start...HELP
    By AraArauna in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 08-02-2011, 04:43 PM
  2. 2000 model Seadoo XP - massive backfires and wont start
    By JTI in forum 2-Stroke Performance
    Replies: 6
    Last Post: 06-03-2011, 05:47 PM
  3. 2000 XPL Wont start,
    By ultramaxracing05 in forum 2-Stroke Performance
    Replies: 31
    Last Post: 06-28-2010, 01:10 AM
  4. 2000 ultra 150 wont start
    By jay00 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-17-2009, 04:08 AM
  5. 2000 Pro 1200 ..Help. Wont start
    By LiquidPro1200 in forum Polaris PWC Performance
    Replies: 25
    Last Post: 08-20-2008, 12:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts