Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    Jul 2011
    Location
    Fort Walton beach fl
    Posts
    7

    Polaris sl900 wont start

    Hello everyone I'm new to this sight and I need some help.
    I have a 96 polaris sl900 that wont start it has rebuilt carbs all new fuel lines and battery is putting out 10.8 volts while trying to crank. Compression is good and all new reeds. Please help
    Thanks


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Do you have spark? Is it the original or updated ignition system? 10.8 volts might be right on the edge...

  3. #3

    Join Date
    Jul 2011
    Location
    Fort Walton beach fl
    Posts
    7
    Yes I have spark and I'm not sure about the ignition

  4. #4
    urugol's Avatar
    Join Date
    Nov 2009
    Location
    Sydney, Australia
    Posts
    1,231
    +1
    3
    I would put a little fuel down each carb throat and try, if you get it to kick over for a second or 2 then you have a fuel delivery problem. You have compression and spark so all you need is fuel to fire, that's where your problem might be.

  5. #5

    Join Date
    Jul 2011
    Location
    Fort Walton beach fl
    Posts
    7
    Well I Charged the battery last night and tried it today and now the starter want turn the engine over at all but if I take out the spark plugs it will turn it over but th battery putts out about 9 volts when trying to crank it but the battery cranks my slt750 good

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    these domestic motors really need a strong battery otherwise you will get no spark. THey are a little more, but get an Odyssey PC 625 and you will have no problems. If that doesnt fire it then you have other issues.

  7. #7
    stubburnjdh's Avatar
    Join Date
    Jun 2009
    Location
    Front Royal VA
    Posts
    365
    I got a good sealed battery at battery mart for 80.00 This is the fifth season on it and still going strong. I put it on a battery minder every winter.

  8. #8

    Join Date
    Jul 2011
    Location
    Fort Walton beach fl
    Posts
    7
    Ok I'll get a good battery and see how it goes. And it does not have the updated ignition or stator do I need to update it even if it ends up working

  9. #9
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    I would suggest doing tthe update anyways. If you get it running, you could then sell the old parts to offset the cost of the new ones

  10. #10

    Join Date
    Jul 2011
    Location
    Fort Walton beach fl
    Posts
    7
    What update kit do I need and were do I get it

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 polaris sl900 wont run
    By hartman in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-28-2010, 06:22 AM
  2. POLARIS SL750 Wont start
    By Happenedtoyou in forum Polaris PWC Performance
    Replies: 4
    Last Post: 07-11-2010, 09:56 PM
  3. Polaris SLT750 Wont Start
    By mkulczyckyj in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 06-15-2010, 05:04 PM
  4. polaris slxh wont start
    By bobbyhill6 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-28-2008, 12:31 PM
  5. 96 Polaris SL900 Not starting
    By XeightyfiveX in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 09-14-2007, 05:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •