Results 1 to 4 of 4
  1. #1

    quick supercharger boost question

    I noticed my boost indicator on the dash is not operating now. What controls this guage incase I did not hook something up right? Thanks


  2. #2
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    plugged ontop of the inlet manifold

  3. #3
    I got some sort of pressure sensor that has a small hose that connects directly from the top of the intake manifold to the sensor. Unplugging it makes it run bad, plugging it in is fine, but no boost indication. Is this the sensor you was refering too?

  4. #4
    nevermind, that is the boost sensor I was looking at, dont know why it just stopped working?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. quick kawa x2 question???
    By massSL780 in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 04-08-2007, 07:29 PM
  2. rr supercharger impeller question
    By Ty in forum 4-Tec Performance
    Replies: 16
    Last Post: 03-12-2007, 09:17 PM
  3. couple quick Ultra 250x questions
    By cue03 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 27
    Last Post: 02-11-2007, 02:34 PM
  4. Supercharger clutch question
    By orange71rt in forum 4-Tec Performance
    Replies: 14
    Last Post: 10-10-2005, 06:44 PM
  5. Boost questions for Jerry..........
    By SKR8PN in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-18-2005, 08:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •