Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    FICHT - no spark, no fuel pressure

    This is in regard to a 1999 tigershark TS 1100 LI with FICHT. I am hoping anyone with a similar system can offer some suggestions.

    I ordered the computer cable and software to read info from the EMM. Upon hooking it up everything seemed normal, I was able to read any codes, clear codes, and run various test. I ran a test for each injector, each ignition coil, etc... All the test appear to work normally. When I disconnected everything and tried to start the engine it will not fire and the fuel pump did not prime the line as it normally does. I double checked all the wiring and everything is plugged back in as it was. The I hooked it back up to the computer again, and all the previous tests still work when in the diagnostics software. Engine still doesn't fire when back to normal state. Is there anything special you have to do after using the diagnostics software? Is it possible I somehow fried my EMM during this test?

    Regards,

    -Inet


  2. #2
    Carson's Avatar
    Join Date
    Jul 2011
    Location
    TX
    Posts
    273
    I don't believe it's your EMM, wait, did you start when it was connected for tests?

  3. #3
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    Didn't forget the lanyard correct? Other than that I would check all the connector pins and make sure something didnt get accidentally damaged (bent pins etc). If it ran before you did the test it has to be something simple. You could try disconnecting the battery for a few minutes and see is something is there that needs to reset. And speaking of the battery, IF your system is like the ones on the Virage and Genesis you will need at least 10.6 volts coming from the battery while cranking the engine or it will not fire.

  4. #4
    rlharrison60's Avatar
    Join Date
    Aug 2007
    Location
    Orange, Texas
    Posts
    1,091
    +1
    1
    You could send your EMM off to DFI and let them check it for you.

  5. #5
    The only time I tried to crank it while connected to the computer was for the running tests. I did not try to run it during the static tests.

    This has to be something stupid simple I'm not doing, but I haven't figured it out yet. Battery is weak now as you mentioned, need to recharge... Will give it a shot tomorrow.

    Does DFI charge a lot to test one?

  6. #6
    with a fully charged battery: no fuel pump, no spark, no injectors firing

  7. #7
    Carson's Avatar
    Join Date
    Jul 2011
    Location
    TX
    Posts
    273
    That has electrical box written all over it. Well the no spark or injectors firing does. As for fuel pump, sounds like corroded lines.

  8. #8

    ecu/emm?

    By electrical box you mean the ecu/emm?

    While connected to the computer, I can run the following tests and they all work:

    - fire injector 1,2,3
    - spark cyl 1,2,3
    - run fuel pump

    When the computer is unplugged and everything is back to normal, the only thing it will do is turn over. There is no spark, the injectors do not fire, and the fuel pump does not prime the line. I wrote to DFI and a tech wrote back stating he did not think it was the ECU. I'm trying to get back in touch with them now to get more info, or send it to them to check it out for sure.

    -Inet

  9. #9
    Carson's Avatar
    Join Date
    Jul 2011
    Location
    TX
    Posts
    273
    EMM

  10. #10
    I continued looking at the wiring the weekend and did not find anything abnormal. After deciding to look at the EMM more closely I found the gel inside to be bubbled up on the rectifier board.

    See picture: http://www.pwcweekly.com/attachment....1&d=1283550055

    The two yellow surface mount capacitors on the left had a brown hole in both of them. When trying to start the ski, they would begin smoking. I could replace them, but am not sure if they are the culprit, or the result of something else which has gone wrong. I am still able to interact with the software and perform all of the following test from the laptop successfully: fire spark plug, fire injectors, run fuel pump, read ECU data, reset any present codes, drop cylinder tests.

    Any suggestions?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 36
    Last Post: 10-21-2016, 06:16 PM
  2. Built 2001 Polaris virage TXI. No fuel pressure, no spark
    By Freight53 in forum Polaris Open Discussion
    Replies: 60
    Last Post: 05-05-2016, 12:50 PM
  3. 04 virage 800 died on river no spark or fuel pressure
    By jimmyg in forum Polaris PWC Performance
    Replies: 1
    Last Post: 04-20-2016, 01:03 AM
  4. 2002 Virage I, NO spark AND no Fuel pressure
    By crazeejames in forum Polaris Open Discussion
    Replies: 12
    Last Post: 07-09-2015, 10:00 AM
  5. Virage 800di Won't Start, No Fuel Pressure??
    By cgustafs in forum Polaris Open Discussion
    Replies: 26
    Last Post: 08-04-2007, 06:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •