Results 1 to 6 of 6
  1. #1
    ndarimont's Avatar
    Join Date
    Jul 2011
    Location
    Aurora, IL
    Posts
    239

    Unhappy Still having problem with power on my 2005 RXT

    I have a 2005 RXT. Last weekend i put it in the water and got alot of muck/mud through the pump. I dile it out of the area and thenshut it outt and shook the ski to clean it out. Started it up again and got on it and it was shaking a bit when accelerating. Shut it off again and let sit. Started back up and rode it again. Felt like it had ok not great straight line acelleration but when cornering hard or trying to flip the back around it would bogg down bad. Brought it home and remove nozzle and pump and found junk jammed in bettween the impeller and wear ring. Cleaned it out and checked wear ring clearance. Found in to have max clearance of .014in and groving in the ring from the junk that was stuck in it. Put back together and went and rode it today. Felt like it still has lower straight line accelleration then normal. Can get the back to flip around some what now but still dosent feel like the ski has the power it did before all this happened. Do i need to replace the wear ring or am i looking at a possible superchager problem that just happened to happen when i suycked the crap up? I went down and moved the supercharger impeller by had and it is very hard to rotate but i can get it to rotate. Please any help/ advise would be great. Engine sounds like it is running fine. Also i am a chrysler technician so i have to know how and tools to work on this to a certain point


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Flush the ski. The IC and exhuast are open loop.

  3. #3
    ndarimont's Avatar
    Join Date
    Jul 2011
    Location
    Aurora, IL
    Posts
    239
    I have already flushed the ski multiple times to be sure there is nothing left in the exhuast or IC. Any other ideas or possibilities?

  4. #4

    Join Date
    Apr 2011
    Location
    Elliott Australia
    Posts
    36
    sounds like wear ring to me, my gtx was doing the same thing and i blamed the sc, so rebuilt it and no diff, swapped wear ring big difference! plus if your sc is real hard to turn it's possible your turning the whole engine with it, need to make sure you have it locked somehow(cam locking tool or do what i did and grip the drive shaft with locking pliers, just be carefull not to score the shaft) hope this helps

  5. #5
    Sell what's left of your ski.....take up moto cross.

  6. #6
    ndarimont's Avatar
    Join Date
    Jul 2011
    Location
    Aurora, IL
    Posts
    239
    ok thanks i will have to try the wear ring then. I will flip it over and see what happens. Also i use to race motocross for 10 years and now i have a job where i cant afford to break something when ever i ride lol

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to install Wake Racks on my 2005 RXT
    By nsschwenk in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-02-2012, 03:01 PM
  2. Only 3000 rpm on my 2005 RXT
    By kaorder1999 in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-08-2011, 08:38 AM
  3. still having problems with 95 800 xp
    By TonyT in forum 2-Stroke Performance
    Replies: 11
    Last Post: 06-21-2010, 07:14 PM
  4. is there a grease fitting on my 2005 rxt
    By lost boyz in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-13-2010, 12:23 PM
  5. Problem with lights on my shorlandr trailer??
    By jasonbedell in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 07-23-2007, 08:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •