Results 1 to 4 of 4
  1. #1

    Join Date
    Jul 2011
    Location
    ct
    Posts
    62

    new on here 300x question

    whats up folks.been lurking on here for a few weeks reading posts since i just bought the 300x.i just did the washer mod yesterday and noticed that the hi rpm recall isnt working correctly anymore and ofcorse the speedo is reading way lower.during the passes i made i can see its turning 7800/7900 but when i hit recall its only reading back 6600.anybody else have this problem with the washer mod.i put 3 washers on the front bolts and 2 on the back.getting the r&d bypass in a few weeks anyway.also its getting its 10 hour service this week gonna have them check the blowoff valve psi.


  2. #2
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    thats because the high rpm is only registered from the highest speed attained so its actually working correctly by showing the rpms at your now low speed reading

  3. #3

    Join Date
    Jul 2011
    Location
    ct
    Posts
    62
    ahhh yes that makes sense thank you.

  4. #4

    Join Date
    Jul 2011
    Location
    ct
    Posts
    62
    gonna order the r&d speed up module.looks to be more user friendly than the other ones.should be out in a few weeks from what i read.i did put a gps on it but it was choppy out and not loosing the pump but bouncing around alot and nothing to write home about @69.8 mph.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New member here with questions
    By 99yamahadave in forum Open Discussion
    Replies: 1
    Last Post: 06-25-2016, 04:50 PM
  2. I'm new here with a 300X question
    By NEWGREENOWNER in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 07-24-2011, 12:32 AM
  3. Hello...new guy here....impeller question
    By perchh in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-09-2010, 05:49 AM
  4. New guy on the block, question..
    By fhenkel in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-30-2007, 08:29 AM
  5. new guy here with some questions???
    By Brueskerxp06 in forum 4-Tec Performance
    Replies: 11
    Last Post: 03-12-2007, 12:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •