Results 1 to 4 of 4
  1. #1

    Need help diagnosing problem

    My '07 250x sucked up a huge clump of sea grass. I cleared the intake grate, but it would only go about 10mph. The revs would climb but the ski would not accelerate. It vibrates noticeably when on throttle and smoked a little out the back. I checked inside the grate after pulling the ski out of water, but it's completely clear. The impeller visibly looks fine. Any ideas what I can check?


  2. #2
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    its probably still stuck in the stator at the rear of the prop.

  3. #3
    What all needs removed to check the stator? thx

  4. #4
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    look in from the rear of the pump with a torch

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gp1200r has no power, need help diagnosing the problem
    By kyle5647 in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-05-2013, 11:11 PM
  2. I Need Help Diagnosing A Problem..
    By mikefeliz7 in forum 2-Stroke Performance
    Replies: 22
    Last Post: 02-17-2009, 06:29 PM
  3. Need Help diagnosing problem
    By Sirhc7897 in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-25-2008, 09:47 AM
  4. New and need help diagnosing my '08 rxtx
    By dr_hunt in forum 4-Tec Performance
    Replies: 50
    Last Post: 06-28-2008, 06:16 AM
  5. Need Help, RXP problems, Plug pictures
    By Water4fire in forum 4-Tec Performance
    Replies: 32
    Last Post: 04-26-2007, 10:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •