Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 40
  1. #1
    TtrahRXPX's Avatar
    Join Date
    Jul 2009
    Location
    Broussard, Louisiana, United States
    Posts
    603
    +1
    2

    Water Leak in ski, need HELP please.....

    So I have an 08' seadoo rxp-x that has 109 hours on the clock. I was at the lake the other day for literally 30 minutes and never cut up what so ever. I get back to the dock and load the ski up on the trailer, i go to unscrew the back left drain plug (valve train side) and a tab bit more than a drop comes out, not much to stress about, rite...... I then unscrew the back right drain plug (Intake/intercooler side) and about 1/8th-1/4 cup of water comes out. I have cut up ridiculously times before with the OEM intake setup and even keeping the ski in the water over nite at my camps and still never had that amount of water come out the drain plug/s. I'm glad I caught it as it wasn't a lot but most I ever had. Usually it's bone dry after a lil ride

    **I have recently added:
    RIVA I/C relocation kit
    RIVA rear exhaust kit
    RIVA Intake manifold upgrade
    Solas 15/22r with s/f nose cone (o-ring still installed in s/f cone from green cone that came with solas prop)


    I don't know what can cause the leak? I do know that the ski was on an incline when I unscrewed the drain plugs but still was enough to get me thinking!

    ANY suggestions for helping me find/solve the problem would be greatly appreciated! I'm trying to make the Morgan City ride as I don't have a bilge system on my ski yet. Don't wanna get caught out in the Bayou with a boat sinking!


  2. #2
    krouchchocolate's Avatar
    Join Date
    Nov 2009
    Location
    Houston, TX
    Posts
    1,224
    +1
    53
    When is the Morgan city ride? You can always buy the bilge pump at your local academy's or something.

  3. #3
    TtrahRXPX's Avatar
    Join Date
    Jul 2009
    Location
    Broussard, Louisiana, United States
    Posts
    603
    +1
    2
    Yep but I'm still wondering where I can look for leaks?!.....

  4. #4
    krouchchocolate's Avatar
    Join Date
    Nov 2009
    Location
    Houston, TX
    Posts
    1,224
    +1
    53
    Quote Originally Posted by TtrahRXPX View Post
    Yep but I'm still wondering where I can look for leaks?!.....

    Maybe your carbon seal. Try riding with your seat off, and see if water comes out around the driveshaft area. Was the water choppy that day? If so, it might just have went over your front hood, and a little water just came into your hull.

  5. #5
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by TtrahRXPX View Post
    Yep but I'm still wondering where I can look for leaks?!.....
    Back the ski into the water still hooked to the trailer. I like to keep the transom straps attached to hold it to the trailer. Take the seat and cowl off and start it up. Looking for leaks is easier this way. You should be able to find the leak that way. Good luck.

    When is the MC ride?

  6. #6
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Check the pump bolts if there not tight your leaking through the crabon seal via loose pump

  7. #7
    TtrahRXPX's Avatar
    Join Date
    Jul 2009
    Location
    Broussard, Louisiana, United States
    Posts
    603
    +1
    2
    Quote Originally Posted by krouchchocolate View Post
    Maybe your carbon seal. Try riding with your seat off, and see if water comes out around the driveshaft area. Was the water choppy that day? If so, it might just have went over your front hood, and a little water just came into your hull.
    Nope, str8 river riding glass


    Quote Originally Posted by MSRXP View Post
    Back the ski into the water still hooked to the trailer. I like to keep the transom straps attached to hold it to the trailer. Take the seat and cowl off and start it up. Looking for leaks is easier this way. You should be able to find the leak that way. Good luck.

    When is the MC ride?
    Trying to get one together this weekend.



    Quote Originally Posted by shrabber View Post
    Check the pump bolts if there not tight your leaking through the crabon seal via loose pump
    You know, this makes total sense. Being Imma be taking the pump off again to get the o-ring out the Speedfreeks nose cone, perfect time making sure bolts are specked rite

  8. #8
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    If u just added rear exhaust I would check that first.

  9. #9
    We had a leak on our bone stock gti the weekend we got it back from having a new motor installed in it at the dealer. We decided to back it back into the water with the seat off and just ran it on the trailer. turns out the dealer "forgot" to tighten two bolts on the top of the motor, causing water to shoot out of the motor and flooding the hull. We called the dealer and sent it back to them and they fixed it on the spot. Shocking how a dealer can just "forget" too tighten a bolt that could have flooded the ski if we had been on a long ride

  10. #10
    TtrahRXPX's Avatar
    Join Date
    Jul 2009
    Location
    Broussard, Louisiana, United States
    Posts
    603
    +1
    2
    Quote Originally Posted by Ocman View Post
    If u just added rear exhaust I would check that first.
    No, the exhaust been installed for about 2 years but I can still check that. Imma go today and do the trailer deal bc I have a feeling that the water came out could have been due to me being on an incline at the boat launch when I was checking my plugs. That's the only thing I can think of. I do know that when I lost a screw while installing the RIVA I/C relo kit, under the motor I felt a little puddle of water that might have been trapped under there. Makes sense for the amount of water that came out when the ski was on the incline the other day. That water could have been in there when it rained or a while before that though and just never came out. I always trailer my ski with the drain plugs screwed tight. It wasn't much but my ski is usually bone dry so, just makes me wonder....

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2009 RXP X 255- Possible water in gas tank - Need help please.
    By danieljreynolds in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-07-2016, 10:25 PM
  2. Bought My first Ski, NEED HELP PLEASE!!
    By tejhummer in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 09-03-2013, 02:22 PM
  3. Yamaha 650, cooling water inlet, need help please
    By devriesd in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 07-02-2010, 10:08 PM
  4. water in engine- need help
    By luciano647 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-25-2008, 08:22 AM
  5. 99 1100 ZXi Water in engine? Need help!!
    By tyler_stephen in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 04-29-2007, 01:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •