Results 1 to 2 of 2

Thread: xp800r problem

  1. #1

    xp800r problem

    I need help with ski. It ran good then lost power and would only run 3-5 mph. I took out of water changed fuel filter and put sea foam in tank and sprayed in carb. It runs well out of water. When put back in water it ran good for a few seconds then slowed down to 3-5 mph. I ran it for a few minutes to let sea foam do its cleaning then it stalled and would only go if the choke was on. When out of water it stared up fine and revved up. I noticed that there was very little fuel in the filter. I checked the check valve by tank and that seemed OK air was only going one way. Please help

  2. #2
    20 feet Boy's Avatar
    Join Date
    Jul 2010
    Bend OR
    This might help plus there are filters in the carbs too that need to be clean. Might do a compression test on the motor too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with xp800r
    By softball in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-06-2011, 09:12 PM
  2. Do you think this could be a problem?
    By ZiGz in forum Polaris Open Discussion
    Replies: 10
    Last Post: 06-15-2011, 10:17 PM
  3. 2002 F12x Idle problem & Mid Range Problem
    By hondarider in forum Honda Performance
    Replies: 9
    Last Post: 07-07-2010, 10:50 AM
  4. 96 XP problem
    By Windjet in forum 2-Stroke Performance
    Replies: 32
    Last Post: 02-26-2010, 10:54 PM
  5. Problem??
    By SHIFT in forum 4-Tec Performance
    Replies: 2
    Last Post: 03-16-2008, 10:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts