Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336

    afr on the 300's

    anyone else hooked up a gauge to see what the #'s are stock or "mostly" stock? care to share your numbers for some comparison ?


  2. #2
    2011 N/A champ 2011-2012 turbo champ elpeladodelsamba's Avatar
    Join Date
    Apr 2011
    Location
    uruguay south america
    Posts
    311
    +1
    1
    not me mike but i will love to see that video from your afr numbers !!!

  3. #3
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    i dont have video of that yet ill work on it today

  4. #4
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    why do you need a video of afr numbers cant you just post them up?

  5. #5
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    Because videos are so much more interesting to look at but Fine, its lean WOT IMO. 12.5 ish maybe a touch richer. But for 15-17lbs boost i woulda thought it richer.... And thats on an 85-90* day

  6. #6
    stangbang's Avatar
    Join Date
    Oct 2007
    Location
    West Palm Beach
    Posts
    844
    +1
    129
    What are you using to monitor the afr?

  7. #7
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    lc-1

  8. #8
    2011 N/A champ 2011-2012 turbo champ elpeladodelsamba's Avatar
    Join Date
    Apr 2011
    Location
    uruguay south america
    Posts
    311
    +1
    1
    video from idle to top rpms would be a +100 video mike. and i honestly love seing you race and boost videos ! does the wideband last long in a pwc ?? or does it has a short life for being in touch with water ¿¿ or i am confused ? is it a place were it is 100% away from water to install? thanks

  9. #9
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    its in the exhaust mani with a heat sink... had one in my doo forever with out a heat sink and it lasted they dont really touch the water. maybe some built up condensation from the WB when it sits but like i said in 2yrs i'm only on my 2nd o2 sensor and the first just went out last week

  10. #10
    2011 N/A champ 2011-2012 turbo champ elpeladodelsamba's Avatar
    Join Date
    Apr 2011
    Location
    uruguay south america
    Posts
    311
    +1
    1
    ok nice so it is safe . i have one with datalogger and i can log 5 or 6 chanels its made by fueltech.com.br it is made in brasil and works like a charm !!

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. So what's everyone getting for prices on the 300? Anyone trade a ski in?
    By Orangecrush in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 01-21-2016, 06:48 PM
  2. VTECH please post up the results from your logging on the 300
    By dpracing in forum 4-Tec Performance
    Replies: 3
    Last Post: 01-03-2016, 01:59 PM
  3. Riva Ultra 250/260 rideplate on the 300/310
    By jetdave56 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 11-04-2014, 11:21 PM
  4. UMI or TBM sterinng on the 300..
    By giguchan in forum Kawasaki PWC Performance (4-stroke)
    Replies: 37
    Last Post: 10-14-2011, 09:15 AM
  5. Oil change on the 300
    By KawaHead in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 08-31-2011, 05:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •