Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    michail's Avatar
    Join Date
    Apr 2008
    Location
    THESSALONIKI,GREECE
    Posts
    302

    rotax racing ecu sensor warning

    Everything works great @ my motor when the oem ecu is connected but when i connect my rotax racing ecu it makes a 2-3 seconds beep and I read just a "sensor" problem.anybody knows what it could be......??

    Please help me....


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    what year/make ski ? Check all your connectors, and u may need to get the dealer to un check the sensor with BUDS (stored in the MPEM) Do u still have the VTS indicator on the display ? does it read 0.0FT , when u scroll through the modes?

  3. #3
    2006 Turbo RXP boBO's Avatar
    Join Date
    Mar 2008
    Location
    STATE OF KUWAIT
    Posts
    1,034
    What model is your ski
    I think you have wrong ECU

  4. #4
    michail's Avatar
    Join Date
    Apr 2008
    Location
    THESSALONIKI,GREECE
    Posts
    302
    It's a '06 rxp .the first time I connected the ecu I had a cam face sensor code(I don't remember the number) and exactly the same code with the oem ecu.but right now the oem works great and the rotax racing creates that problem.I have deleted the vts so it's not connected.
    I forgot to tell you that the engine starts up but I don't have a normal idle and when i open the throttle it makes a break and afterwards it revs well!

  5. #5
    michail's Avatar
    Join Date
    Apr 2008
    Location
    THESSALONIKI,GREECE
    Posts
    302
    The rr ecu it's programmed by easy rider @ 8800rpm.

  6. #6
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,693
    +1
    40
    Thats a wrong year ecu!
    I had the same problem with a rr 07 ecu on a 08 ski!

  7. #7
    michail's Avatar
    Join Date
    Apr 2008
    Location
    THESSALONIKI,GREECE
    Posts
    302
    I don't think so because it's a 06 ecu send by me to easyrider asking him to change the rev limit.and right now it's a 8800rpm ecu.

  8. #8
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,693
    +1
    40
    Quote Originally Posted by michail View Post
    It's a '06 rxp .the first time I connected the ecu I had a cam face sensor code(I don't remember the number) and exactly the same code with the oem ecu.but right now the oem works great and the rotax racing creates that problem.I have deleted the vts so it's not connected.
    I forgot to tell you that the engine starts up but I don't have a normal idle and when i open the throttle it makes a break and afterwards it revs well!
    Did you do the 0-100% throttle reset once you plug it to the ski?

  9. #9
    GTLaser's Avatar
    Join Date
    Aug 2009
    Location
    MD
    Posts
    330
    Quote Originally Posted by mitsakosgt View Post
    Did you do the 0-100% throttle reset once you plug it to the ski?
    Is this needed with all rr ecu's? if so how do you do it? thanks

  10. #10
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,693
    +1
    40
    Quote Originally Posted by GTLaser View Post
    Is this needed with all rr ecu's? if so how do you do it? thanks
    It is needed only at the first time you plug the ecu on the ski to read the tps!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. P-0326 knock sensor code + Rotax Racing Ecu
    By trofodotiki in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-30-2014, 02:29 PM
  2. B-kit with a Rotax Racing ECU without extra fuel STOP NOW!
    By bttek1 in forum 4-Tec Performance
    Replies: 49
    Last Post: 05-16-2006, 04:10 PM
  3. Reflash to newer program for Rotax Racing ECU
    By Green Hulk in forum 4-Tec Performance
    Replies: 67
    Last Post: 01-08-2006, 03:41 PM
  4. Who is in for the Rotax Racing ECU upgrade?
    By Green Hulk in forum Sea Doo Open Discussion
    Replies: 38
    Last Post: 12-13-2005, 02:31 PM
  5. RXP ECU vs ROTAX RACING ECU for 2004 GTX SC LIMITED
    By Totallyblown in forum 4-Tec Performance
    Replies: 4
    Last Post: 11-19-2005, 05:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •