Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Jul 2011
    Location
    Las Vegas,NV
    Posts
    16

    Some Questions about my 300X

    How do you feel about the 5 hr break in period do you feel that is sufficient or is more or less time needed?

    How often does everyone use the fogging oil? every ride?
    What brand?

    How often do you change the spark plugs?

    I have 2.5 hrs on my ski and still need to do the steering slop fix and prop issue with some loctite. I need detailed info and pics cause this is my first kawaski since my 1997 750 XiR i guess i need to order a helms manual. Thanks for the help guys


  2. #2

    Join Date
    Jul 2011
    Location
    Las Vegas,NV
    Posts
    16
    Also air temp guage is only reading 89 and its over 110 in vegas?

  3. #3

    Join Date
    Dec 2010
    Location
    ramona ca
    Posts
    54
    +1
    4
    I did the break in for 5 hours and that is enough,foggin i talk with a guy who knows a lot about the ultras and he said every 2 rides foggin a little and then if you going to store or not use for a long time do it again,i have kawasaki foggin oil and one for autozone is the same, about spark plugs i really i dont know mine has 15 hours run perfect but is a guy with around 40 hrs and he is using the originals s.plugs

  4. #4
    JET250's Avatar
    Join Date
    Jan 2008
    Location
    Australia mate fair dinkum.
    Posts
    1,278
    +1
    2
    20 Min warm up then ride it like ya stole it. Search for break in there's enough been said on this already. If you ride in the surf fog every ride. Don't store it ride all the time change plugs when they stop working....

  5. #5
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9
    Quote Originally Posted by JET250 View Post
    20 Min warm up then ride it like ya stole it. Search for break in there's enough been said on this already. If you ride in the surf fog every ride. Don't store it ride all the time change plugs when they stop working....
    +1

  6. #6
    Quote Originally Posted by allmotrek24 View Post
    Also air temp guage is only reading 89 and its over 110 in vegas?
    Can you show the pic of the dash meter?

  7. #7
    The other day my air temp read 89 and my water temp read 108, the water in my hot tub is 105 I doubt the water in the river was 108. The air temp seems o.k. but the water temp is nowhere near close. I dont know if there is a way to calibrate it, I may aske the dealer in the off season.

  8. #8
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9
    My temps are not accurate either. It would be kinda cool if it did work though....

  9. #9
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Nether of mine work and my air temp isn't even under the pad anymore open air and never even close to right. The water temp is off as well but nit suprised as the temp sensor is in the intercooler

  10. #10
    rsg1963's Avatar
    Join Date
    Jul 2008
    Location
    Dublin, Ca. USA
    Posts
    90
    5 Hours is fine. It's really the first 20-30 minutes and then get's less and less important as time goes on. How you heat and cool the block is an important part of the break in. Kind of like tempering it. Vary that throttle and avoid hard pulls (launches) and WOT for more than a few seconds and you'll be fine.

    I have 45 hours on my ski with original plugs but have spares just in case. I will not change them until I have to. I fog at the end of every day and I only run lakes and rivers (no salt). It's most likely overkill, but I'm not chancing it.

    I use Fluid Film for fogging and the engine exterior.

    Not sure you will find detailed pics and steps on some of the fixes here. There are a lot of high-end racing types and they are not so patient with the recreational crowd and their simple needs. But you might get lucky, who knows! I seem to remember a steering fix walk through but you'd need to search for that.

    Also, I changed my oil and filter with a K&N and Amsoil Marine grade synthetic @ 17 hours. I plan on changing it again @ 50 hours, then every 50 after that.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Some questions about my 2013 fx sho - warning lamp, cruise control
    By Titanup16 in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 09-23-2016, 10:30 PM
  2. Some questions about my brand new 2015 Rxp-x 260
    By Lstorm2003 in forum 4-Tec Performance
    Replies: 17
    Last Post: 09-21-2015, 08:01 PM
  3. I have some questions about my Kawasaki Ultra 250x
    By Trento in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 06-04-2010, 07:51 AM
  4. A few questions about my RXP
    By Teddy57 in forum 4-Tec Performance
    Replies: 2
    Last Post: 01-28-2006, 02:22 AM
  5. question about my 05 gtx ltd.
    By chazavw in forum 4-Tec Performance
    Replies: 15
    Last Post: 12-02-2005, 02:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •