Results 1 to 2 of 2
  1. #1

    Join Date
    Aug 2011
    Augusta, GA

    Question 2000 Genesis FFI..runs fine but won't move forward or reverse

    Hello from a new member and someone who knows nothing about my ski.

    Mine will crank and run fine but it won't move forward or reverse..the impeller seems to have "slipped" on the shaft and is not turning at all when the shaft turns.

    I would welcome any comments that may help...except "take it to a dealer"..I've called them and they want a small fortune to do I'm going to do it

    Thank you....

  2. #2
    casey67's Avatar
    Join Date
    Sep 2006
    The most common part,is the coupler on the back of the engine.

    Take it apart to make sure there isn't other damage to the driveshaft

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Polaris Genesis FFI won't go over 4000 rpm
    By Rick240 in forum Polaris PWC Performance
    Replies: 13
    Last Post: 12-06-2012, 03:40 PM
  2. Replies: 5
    Last Post: 05-24-2012, 01:29 PM
  3. 2000 genesis ffi
    By drwebb69 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 04-20-2010, 04:58 PM
  4. 99 Genesis Runs great doesnt move
    By exithead in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-31-2008, 03:00 PM
  5. Engine fine, won't move
    By chhemo in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-27-2007, 03:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts