Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    Join Date
    Jul 2007
    Location
    hawkesbury ontario
    Posts
    127

    2011 rxt 260 riva stage 1

    well got it all together and went on water .
    80f water and 85 degree humidity

    only getting 7600 rpm?


  2. #2
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    hmmm - you might want to check your impeller pitch or for a boost leak.

  3. #3
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    Boost leak - check hose clamps on SC to IC and IC to TB - I'll bet a Shiner Bock on it!

  4. #4
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455
    Quote Originally Posted by jpt7779 View Post
    Boost leak - check hose clamps on SC to IC and IC to TB - I'll bet a Shiner Bock on it!
    +1 to Shiner Bock

  5. #5

    Join Date
    Jul 2007
    Location
    hawkesbury ontario
    Posts
    127
    i check clamps they all dont move

  6. #6
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    How many hrs do you have on it?

  7. #7

    Join Date
    Jul 2007
    Location
    hawkesbury ontario
    Posts
    127
    8 hours

  8. #8

    Join Date
    Jul 2007
    Location
    hawkesbury ontario
    Posts
    127
    ok so i rechecked all hoses to and clamps . all good pulled kanaflex off super charger to run staright now i get 7700 7720 .mean time i loose bolt that tightens clamp on . ouff not happy

  9. #9

    Join Date
    Jul 2007
    Location
    hawkesbury ontario
    Posts
    127
    i should also mention i am running no catch can .as it has come in yet

  10. #10
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    I wouldn't just check tightness on the clamps, take the hose off - wipe inside hose and fitting(SC/IC/TB) with isopropyl alcohol and reattach while wet(this is a service bulletin).

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 RXT-X 260 (RIVA Stage 1 Racing Kit Performance)
    By RDB19 in forum 4-Tec Performance
    Replies: 38
    Last Post: 07-20-2011, 08:12 AM
  2. 2011 rxt 260 vs 2007 rxp riva stage 1
    By chokehold in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-18-2011, 03:44 PM
  3. 2006 RXT with Riva Stage II Kit - $6,000
    By seatsR4toilets in forum Sea Doo 4Tec Skis
    Replies: 9
    Last Post: 05-26-2009, 02:32 PM
  4. rxt-x riva stage 1
    By chokehold in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-28-2008, 06:48 AM
  5. RXT w/ Riva stage 1 or 2 kits questions
    By Mark S in forum 4-Tec Performance
    Replies: 7
    Last Post: 02-21-2006, 05:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •