Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    Jun 2011
    Location
    Fort Worth, Tx
    Posts
    13

    97 SLTX stalls after running then starts right back up

    I have a 97 SLTX that runs great for around 10 minutes then will just die. It will immediately start back and goes for another 10 minutes and dies again. It will run all afternoon repeating the same thing.


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Has the engine been rebuilt lately?

  3. #3
    I like Boobs. wetwolf's Avatar
    Join Date
    Nov 2005
    Location
    The NSA know's that I'm in Spokane, WA
    Posts
    805
    +1
    106
    Make sure you re running resistor plugs, non resistor plugs will cause this problem. Also, make sure that the fuel tank vent is functioning properly. Could be a stuck check valve on the vent in hose.

  4. #4

    Join Date
    Jun 2011
    Location
    Fort Worth, Tx
    Posts
    13
    Original motor, it has good compression 135. I am running bpr8es and I haven't checked the check valve.

  5. #5

    Join Date
    Jun 2011
    Location
    Fort Worth, Tx
    Posts
    13
    I replaced both check valves on fuel lines and still have same problem. It has all new fuel lines and carbs have been gone through.

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    Does this ski have the updated ignition?

    Original may be getting hot and starting to fail.

    Any warnings on the MFD?

    Hot or anything like that?

  7. #7

    Join Date
    Jun 2011
    Location
    Fort Worth, Tx
    Posts
    13
    It doesn't have the updated ignition. I am planning on doing it this winter but I thought those failures were more it would die after getting hot and not start back up?

    MFD doesn't work? I have also tried disconnecting it and that doesn't help.

    Cylinders are never too hot.

  8. #8
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Check the fuse for the MFD. I would highly recommend the ignition update asap

  9. #9

    Join Date
    Jun 2011
    Location
    Fort Worth, Tx
    Posts
    13
    The fuse is good. All contacts looked good inside box.

    I do plan on doing ignition update but I do not want to replace parts without first finding the problem.

  10. #10
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    Well, does it feel fuel or electrical related to you?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 09-26-2012, 02:44 PM
  2. 2001 Virage xt 1200 help. Ski dies randomly, starts right back up.....
    By Piranha Performance in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-20-2012, 10:23 AM
  3. Replies: 2
    Last Post: 03-16-2012, 11:41 AM
  4. Replies: 9
    Last Post: 05-06-2011, 07:53 AM
  5. polaris sl780 cuts out but starts right back up?
    By polaris in forum Polaris Open Discussion
    Replies: 6
    Last Post: 10-08-2008, 11:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •