Results 1 to 5 of 5
  1. #1

    Join Date
    Jul 2011
    Location
    canada
    Posts
    297

    rxt stage 3 power problem need help

    i my problem begin 2 weeks ago when my riva ic gen (vortec) begin to have a big leak.
    i notice the problem when my seadoo begin to lose power and rpm.

    i order the brand new one riva gen 2 ic (vortech)
    i receive it today and its allready install.
    i just come home from the first test
    the problem is in the first time (30 min ago) my rxt was capable to do 8240rpm and in the end(10 min after) i was just capable to do 7600 rpm.
    do you think is my supercharge or just something is just not install correctly.

    i have alot of torque and power but now my rxt just do 7600 rpm

    seadoo rxt stage 3 (2007)
    please need help
    sorry for my english im from canada quebec


  2. #2
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    . I'd say boost leak. check all hoses.

  3. #3
    HardmanGT's Avatar
    Join Date
    Aug 2009
    Location
    Rutherfordton, NC
    Posts
    459
    +1
    3
    sounds like the supercharger is slipping to me. Doe you get the RPMs back after a long cool down?

  4. #4

    Join Date
    Jul 2011
    Location
    canada
    Posts
    297
    im going to try again tomorrow and i going to check all the connection to be sure to have no boost leak

    what is the sign to check if my supercharge slipping

  5. #5

    Join Date
    Jul 2011
    Location
    canada
    Posts
    297
    Quote Originally Posted by Sturm215 View Post
    . I'd say boost leak. check all hoses.
    thanks alot
    the boost leak was my problem

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wierd Starter relay problem....NEED HELP???
    By jitees in forum 4-Tec Performance
    Replies: 18
    Last Post: 03-20-2010, 06:19 PM
  2. New parts-New Problems-need help
    By HoopsRXT in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-11-2007, 04:44 PM
  3. GP1300R problem: need help!
    By Mr Bill in forum Yamaha PWC Performance (2-stroke)
    Replies: 16
    Last Post: 07-23-2007, 06:58 PM
  4. 02 1200r Power Problem please help
    By team11haro in forum Yamaha Open Discussion
    Replies: 10
    Last Post: 03-23-2007, 02:05 PM
  5. Seadoo GTX problem Need help!
    By DeeGee in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 06-17-2006, 11:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •