Results 1 to 9 of 9
  1. #1

    Do I need to replace the impeller or wear ring?

    Hi all,

    I have a 2004 FX140. There is an obvious gap between impeller blade and the wear ring(impeller housing). It is sluggish off the start. My plan is to replace the wear ring, but could the issue be a worn impeller? Is there a way to check?

    Thanks


  2. #2
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    If there is an obvious gap, best bet is to send the whole pump to who ever you plan on using and letting them take care of it.....

  3. #3
    why did all the great replies disappear and I'm left with this useless post? Is there a better forum for waverunner repairs?

  4. #4
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Useless? thats your option.............

  5. #5
    Addicted Member 5001craig's Avatar
    Join Date
    Jul 2007
    Location
    Northeast Indiana
    Posts
    2,924
    +1
    11
    Quote Originally Posted by weatherman View Post
    why did all the great replies disappear and I'm left with this useless post? Is there a better forum for waverunner repairs?
    I would say that you'll get more flies (or answers) with honey as opposed to vinegar around here.

    Aqua is giving you sound advice above IMO because if your prop is worn a shop can bring it back to the correct diameter. The same shop can fix your liner too.



    Oh, and this is the only PWC forum. Period.

  6. #6
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Quote Originally Posted by 5001craig View Post
    Oh, and this is the only PWC forum. Period.

  7. #7
    yep. Useless. There were some great replies until the server crashed. Then you guys showed up with nothing. BTW, it's opinion, not option dumbass.

  8. #8
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    you know what its supposed to be OPTION....because if you have a gap you have wear, your option is to send it to a shop and have them put it back in to spec JACKASS......

  9. #9
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    And if you have to ask such a dumbass question in the first place, maybe you should find another hobby.....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Virage TXi possible impeller problem, need to replace the entire jet pump
    By Keeper1343 in forum Polaris Tech Tips and Info
    Replies: 25
    Last Post: 05-17-2014, 10:27 AM
  2. Replies: 1
    Last Post: 07-16-2011, 09:50 AM
  3. Do i need to replace this impeller
    By Saywoodj in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-23-2008, 12:48 AM
  4. When do i need to change the an old Intercooler
    By LAB69 in forum 4-Tec Performance
    Replies: 3
    Last Post: 02-05-2007, 11:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •