Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10

    New (to me) SLXH

    Previous owner couldn't get her running so he let her go with trailer for $800. I must have gotten Polarisitis ... couldn't pass up.
    Checking thru everything looks like carb cleaning is only thing required to get her running, but having Polarisitis I'm sure I'll go further than just the carb before putting her back in the water.
    She came with Tau Ceti F/A, after market sponsons and extra coil. I also noticed starter relay is mounted outside the e-box. Evidently there're some kind of mod have been done, so with luck I may have the updated ignition.

    Compression 130 128 130
    Hull/Paint see photo
    Ski ran when pour gas down carb throat

    Click image for larger version. 

Name:	20110805_002.jpg 
Views:	44 
Size:	97.5 KB 
ID:	248530
    Click image for larger version. 

Name:	20110805_003.jpg 
Views:	56 
Size:	88.5 KB 
ID:	248532
    Click image for larger version. 

Name:	20110805_004.jpg 
Views:	38 
Size:	65.8 KB 
ID:	248531


  2. #2
    Carson's Avatar
    Join Date
    Jul 2011
    Location
    TX
    Posts
    273
    That is a beautiful ski, and we can't get mad at that Polarisitis. Imagine what could've happened to the ski if you didn't buy it?!

    -Carson

  3. #3

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Nice and it already has the Newer Seat on it and Hotseat sponsons

  4. #4
    1FASTXC's Avatar
    Join Date
    Mar 2007
    Location
    Wisconsin
    Posts
    412
    +1
    2
    Check the fuel lines at the pickup. I bought a ski one time that the previous owner swapped the pickup line with the return line so it wouldn't pickup any fuel. Swapped them around and it fired right up.

  5. #5
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    Already planned on at least these before hitting the water:
    - Clean/rebuild carb
    - Replace all fuel lines
    - Check head and wash
    Whether fuel lines were swapped or not, they will be right when I'm done

  6. #6
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    34
    That looks like an Old "Ford" starter relay,probably alot cheaper than Polaris relay.
    Make sure the little decal says something about "diode". Then it should work fine.Are there 2 small wire terminals ?
    Double check all other ground wires, especially the batt ground cable.

  7. #7
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    Thanks for the tip casey67!
    Yes there're 2 wires running to the e-box, sanwiched between the seals. I haven't started working on her yet ... til honey-doos are finished

    Hey, just realize that I can have "almost" identical avatar as yours (01 SLX & this SLXH on double trailer)

  8. #8
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    34
    LOL... you'll have me beat, The yel/blk one is a '97.

  9. #9
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    The work has begun!
    Had the carbs out and cleaned today, but by the look of oring and diaphragm I'll need to get rebuild kits to finish the job properly.
    Found the fuel problem; stuck needles, cracked diaphragm and pin prick hole in the fuel pump flap.

    The jettings are quite higher than stock like 5 over for Mid and 10 over for Hi, kinda makes me wonder if that is because of the F/A or there's something else in the engine ...? I really don't think they need to go up that much just for F/A.
    With limited time I had today, carb is all I could go through. Looks like I'll need to check the head see if I can find the answer for the fat jettings.

  10. #10
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    Popped the heads open yesterday, I was expecting some wash but there were virtually none !!? Just the Mag has 2 small pinkies, the rest is just black. So my quest for the fat jetting reason continues ...

    However, I did notice this nice blend on the exhaust. Is it stock or answer to my quest?
    Many thanks,
    Click image for larger version. 

Name:	20110807_004.jpg 
Views:	28 
Size:	71.6 KB 
ID:	248722

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New to me for electrical wiring
    By lafjax in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 07-16-2007, 04:31 PM
  2. New to me 95 SLT 750
    By 95SLT750Rider in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-08-2007, 05:26 PM
  3. new to me sl780 issues
    By starflight in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-08-2007, 04:28 PM
  4. need help 96 speedster new to me
    By lp*rp in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 06-26-2007, 07:45 PM
  5. Got new to me Ski
    By Rodneyae in forum Polaris Open Discussion
    Replies: 11
    Last Post: 03-18-2007, 05:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •