Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    video of boost at wot?

    anyone have a video of the factory boost guage at wot?


  2. #2
    2011 N/A champ 2011-2012 turbo champ elpeladodelsamba's Avatar
    Join Date
    Apr 2011
    Location
    uruguay south america
    Posts
    311
    +1
    1

    here you are!!

  3. #3
    awesome thanks. Seems my ski has a issue then. At wot the boost doesnt stay at 15 (ish) it drops to about halfway between 10 and 15. only happens once it is up there in speed. Is this normal? Also my ski is only running about 7400 rpms now, use to run 7600 to 7700. only has 6 hours on it. When you grab a handful from a dig it gets up fine and boosts fine then seems to die off....

  4. #4
    If yours is 100% stock then that seems about what my ski did stock, right around 12.5-13 lbs of boost and 7,500 - 7,600 at 67 mph. washer mod got it up to 7,850 and 13.5 lbs of boost at 70-71 mph.

  5. #5
    2011 N/A champ 2011-2012 turbo champ elpeladodelsamba's Avatar
    Join Date
    Apr 2011
    Location
    uruguay south america
    Posts
    311
    +1
    1
    it is normal cause when the speed limiter comes in the boost lowers to 12.5 psi. install riva speed override module or washers so at full speed rpm+s stay at 8k and boost arround 14psi (stock)

  6. #6
    ok this is good to know. Any gains in using the wastegate block off plate?

  7. #7
    Also, don't get too hung up on the actual number, from this video it looks like the stock lcd gauge may be off a couple of lbs. In the video the mechanical gauge is reading 15psi and is spiking to 16, while the digital gauges is only reading ~14, who knows.. http://www.greenhulk.net/forums/show...-what-you-will

  8. #8
    Quote Originally Posted by Chris288 View Post
    Also, don't get too hung up on the actual number, from this video it looks like the stock lcd gauge may be off a couple of lbs. In the video the mechanical gauge is reading 15psi and is spiking to 16, while the digital gauges is only reading ~14, who knows.. http://www.greenhulk.net/forums/show...-what-you-will
    good point....

  9. #9
    which override module do you guys feel is better the r&d that is coming out (end of august) or the riva one? Think it would be worth it to install the wastegate block off plate?

  10. #10
    To me it looked like the r&d module was a more " plug and play " but it looks like there is still a sense wire that you will have to dig into the wiring harness to remove/replace, only thing that looks easier is the fact there is a connector for the power rather than going to the battery terminals. If you want one now, go with the Riva, they do the exact same thing IMO. oh, and the R&D is 50.00 cheaper,

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra 250x - half boost at WOT?
    By bdrilling33 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 05-30-2015, 05:14 PM
  2. rxpx 2012 missing 1 bar of boost at wot
    By spacerrr in forum 4-Tec Performance
    Replies: 11
    Last Post: 11-17-2014, 09:55 PM
  3. 250 Loosing Boost at WOT
    By Aquaholic6801 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 05-14-2009, 07:17 PM
  4. Here is a video of my corvette at the track 2 weekends ago
    By racerrob333 in forum Open Discussion
    Replies: 9
    Last Post: 04-01-2008, 06:41 AM
  5. Video of my throttle postion at WOT
    By MIARider in forum 4-Tec Performance
    Replies: 17
    Last Post: 09-05-2007, 01:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •