Results 1 to 3 of 3
  1. #1
    gp69rxp's Avatar
    Join Date
    Aug 2010
    Location
    Milford, CT
    Posts
    24

    Xp 787 won't run for shit

    Ok here's the deal. My xp 787 won't run. I took it out one day after cleaning the carbs and hooking the vts back up and since then it won't run. It sputters but that's about it. Here's a list of what I have done so far and some of the things I have found.
    New battery
    New voltage regulator
    New stator
    New coil
    New plugs
    Fuel mixture is definateley too richlike 30:1
    Cleaned and thoroughly inspected carbs - even tried a new set
    Compression 147 on both
    Has Spark but seems week on both
    Checked all fuses
    Definateley getting fuel
    Kind of wants to backfire out of the intake
    When I put my finger in the intake hole on the rear cyl. I found metal shavings
    Trying to start it without the air filters (shouldn't make a difference but ya never know)

    I'm at a loss - any help would be greatly Apprieciated.


  2. #2
    canuck's Avatar
    Join Date
    May 2006
    Location
    The wet left coast.
    Posts
    1,088
    +1
    108
    Quote Originally Posted by gp69rxp View Post
    Ok here's the deal. My xp 787 won't run. I took it out one day after cleaning the carbs and hooking the vts back up and since then it won't run. It sputters but that's about it. Here's a list of what I have done so far and some of the things I have found.
    New battery
    New voltage regulator
    New stator
    New coil
    New plugs
    Fuel mixture is definateley too richlike 30:1
    Cleaned and thoroughly inspected carbs - even tried a new set
    Compression 147 on both
    Has Spark but seems week on both
    Checked all fuses
    Definateley getting fuel
    Kind of wants to backfire out of the intake
    When I put my finger in the intake hole on the rear cyl. I found metal shavings
    Trying to start it without the air filters (shouldn't make a difference but ya never know)

    I'm at a loss - any help would be greatly Apprieciated.
    Did you drop anything down the intake ? This would jam the rotary valve and strip the RV shaft.

    Are there any brass fillings in the RV oil lines ?

    I would pull the RV cover and check the timing.

  3. #3
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,525
    +1
    1,270
    +1 on a rotary valve problem, spitting out of the carb is a number one sign of rv failure.

    oh yeah..metal shavings..

    BAD

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 96 XP 787 parts for sale
    By airbornexp in forum Sea Doo Classifieds
    Replies: 89
    Last Post: 01-18-2011, 06:40 PM
  2. 95 xp runs for 10 minutes then dies
    By 95xprider in forum 2-Stroke Performance
    Replies: 12
    Last Post: 06-09-2010, 03:37 PM
  3. 96 xp 787 won't start
    By austind in forum 2-Stroke Performance
    Replies: 5
    Last Post: 05-25-2009, 10:49 PM
  4. 97 XP won't run under load please help
    By jared427 in forum 2-Stroke Performance
    Replies: 9
    Last Post: 05-16-2009, 06:02 AM
  5. virage won't start after running for a while
    By culby-wan-kanobi in forum Polaris PWC Performance
    Replies: 27
    Last Post: 08-07-2008, 02:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •