Results 1 to 2 of 2
  1. #1

    a little help...

    we have a " maint" light on and the motor according to my step son it is in limp mode. is there a way to clear the code ? Does it have anything to do with us changing the oil at the begining of the season...( money is tight and would like to avoid the dealer right now..( who says all we can do is service it and charge you $360 i told them we did the oil...they dont seem to care)

    signed too many toys not enough time or money LMAO...


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,931
    +1
    1,407
    Welcome to the Hulk.
    The maintenance light will not cause "Limp mode". Are there any codes displayed?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need a little help please...
    By lafjax in forum 4-Tec Performance
    Replies: 18
    Last Post: 09-08-2006, 07:00 PM
  2. A little help needed
    By Top banana in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-07-2006, 03:12 AM
  3. Need a little help from all your HULKsters!
    By beachboy66 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-20-2006, 07:38 AM
  4. Little help please
    By CRAZEDRXP in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 06-01-2006, 02:38 PM
  5. Can some one Post! A little Help Please!
    By Angelse68cal in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-04-2005, 07:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •