Results 1 to 3 of 3
  1. #1

    blaster 2 problem...

    i had my blaster 2 out the other day in the inlet and it shut off on me after 20 min and would not fire back up again. Had it running in the driveway the night before plugged into the hose and the morning of before we left and everything was running fine. What would cause it to stop running? Is there anything under load that would cause it to shut off? I got it running the other night in the driveway again and had no problems. Any help would be appreciated, thanks in advance!


  2. #2
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,326
    +1
    49
    Does it spin over good when it wont crank?
    What is the compression.

  3. #3
    it cranked good that day but just wouldnt fire back up, im going to check the compression after work tomorrow.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. blaster 1 problem
    By Edwin in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-20-2009, 10:28 AM
  2. Blaster running problem
    By Sleepin in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 10-10-2008, 03:45 PM
  3. major blaster 1 problem please help
    By buzz in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 03-06-2008, 09:02 PM
  4. major blaster 1 problem please help
    By buzz in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 03-05-2008, 02:22 PM
  5. 96 BLaster II Idle problems
    By RxP Jumpin in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 04-22-2007, 01:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •