Results 1 to 3 of 3
  1. #1
    warner0308's Avatar
    Join Date
    Apr 2011
    Location
    mchenry,il.
    Posts
    519
    +1
    3

    Question 2004 rxp 7650 rpms

    all right guys what am i missing, it ran 7950 when i got it. changed supercharger (with a good one ) plugs and oil. now it will only spin 7400 to 7650? not a boost leak sprayed it all down with soapy water started it and no bubbles any where.also reved it to make plenty of boost. oil level good, plugs correct. where do i go next? would a wear ring cause low rpm? thanks guys,


  2. #2
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by warner0308 View Post
    all right guys what am i missing, it ran 7950 when i got it. changed supercharger (with a good one ) plugs and oil. now it will only spin 7400 to 7650? not a boost leak sprayed it all down with soapy water started it and no bubbles any where.also reved it to make plenty of boost. oil level good, plugs correct. where do i go next? would a wear ring cause low rpm? thanks guys,
    Yes! A bad wear ring can contribute to low RPM's. Remove the Cam sensor and map sensor and clean off and re install. I would also remove the crank position sensor and clean it off. They are magnetic and if any metal gets on them they go nuts.

  3. #3
    RXP in upper Michigan flnsx's Avatar
    Join Date
    May 2007
    Posts
    70
    Quote Originally Posted by MSRXP View Post
    Yes! A bad wear ring can contribute to low RPM's. Remove the Cam sensor and map sensor and clean off and re install. I would also remove the crank position sensor and clean it off. They are magnetic and if any metal gets on them they go nuts.
    Where are all the sensors located? Are they hard to access or take out and clean?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 rxp lost rpms with stage 2 kit
    By hilltopbrent in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-25-2010, 07:43 PM
  2. 2004 RXP surging RPM
    By NJMatt50 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-21-2008, 05:06 PM
  3. 2004 rxp rpm's?????????
    By soldierpage in forum 4-Tec Performance
    Replies: 19
    Last Post: 05-04-2008, 12:32 PM
  4. 2004 rxp stock only 7600 rpms,63 mph
    By joe563 in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-01-2007, 12:46 PM
  5. HELP!! my 2004 rxp had low the RPM's at full throttle
    By rafyrxp in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 06-17-2006, 11:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •