Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    Need help with RXPX

    hey guys, I been lurking these fourms for quite some time, very helpful in choosing what ski to buy.

    anyways I bought a used 08 RXPX, 109 hours on it, took it out for the first time today and noticed it topped out at EXACTLY 70 mph, which is a decent top speed but the way it rushed to 70 like a bat ut of hell and just BOOM topped seemed very off, it was 7400 rpm (jumping up to 7440 the back down to 7400) im just wondering is this normal? or is there some sort of a govener?

    Thanks guys


  2. #2
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    No. Not normal. You should be seeing 8120-8160 rpms. The speedo on the dash is not accurate. Sounds like the charger is slipping or you dropped a washer. What does the wear ring and prop look like? Did it hesitate out of the hole when you punched it from a dead stop. Banged the limiter and then went? If so your wear ring is toast. Pull the pump and check it out. Easy easy easy.

  3. #3
    no issues out of the hole at all, never tapped a rev limiter

    is there a mod that can limit the rpm's more?

    also if theres another 800 rpm what does this thing top out at?

  4. #4
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    8200 is the limiter. Sounds like the slip needs to be set. Was it rebuilt at the 100 hr mark? If not, you need to have that done. Thread for that is at the top of the page in the sticky's called SC Rebuild Service.

  5. #5
    it was done at 109, right before I bought it from the dealership. now setting the slip is on the SC? sorry im super new to this

  6. #6
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    If it was rebuilt then the slip was set. There is something going on that is is 800 rpms down. Something is not right.

  7. #7
    if the slip was corrected, I wont lose this INSANE holeshot will I? i have grown fond of it lol

  8. #8
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    The speedo will not read past 70 no matter what on a stock ecu. You could be doing 75mph on GPS and it will only read 70 mph. Are you sure about the rpms you are seeing, because I am pretty sure I haven't seen a stock PX hit 70mph on the stock speedo at 7400 rpms.

    You should be seeing 8000-8100 on a PX, if the weather is decent. If its smoking hot out, maybe a little less than 8000.

    This is all on a stock PX.

  9. #9
    im not sure if its stock or not, bought it used, and not to sound like a honda civic owner but it has few stickers from performance shops lol

  10. #10
    the speedo not going past 70 explains alot, when it hit 70 it was at like 7150 - 7200 and from that rpm til 7400 no change in mph.

    now is there ANY possible mod that the first owner could have done to make lower rpm's?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with the XLL
    By Smitty in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 05-23-2006, 09:39 PM
  2. Need help with pump issue
    By Flyer in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-23-2006, 05:40 PM
  3. OK, need help with the small stuff now
    By Smitty in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 05-13-2006, 01:55 PM
  4. Need help with a Sony Handycam
    By kenshin89 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 04-27-2006, 06:42 PM
  5. Need help with 04 S.C. rebuild
    By Turbo Todd in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-10-2006, 08:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •