Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    runs better at half throttle sl650

    bumped timing to advanced mark on stator..... installed 107.5 mains right now turned screws on mains to about 3/4 annd as said in title if I "pin it" she slows in rpms if I hold it at half I can pull about 4500 rpm's with my tto tach and math I have to do.Rpm's seem to get better the more I turn mains in.Jets too big? plugs black to gray see sig. for mod's thanks ,Nate


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Plugs black is rich, plugs GRAY means aluminum.

    Check your piston wash

  3. #3
    I've looked at wash.....only ridden for 1hr tops can't see any "change" I've got a #90 jet for a fuel restrictor could dropping that to say a 60 help? Could I be over jetted on mains.Trying to adjust for F/A and wash and max RPM's at the same time.Maybe I got too much going on at once.

  4. #4
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    I think 107.5 jets are way too big on a 650. 90s or 95s were stock on the 95 SL650s depending on engine serial number. At most I would think 97.5s would be big enough. I noticed in your signature, 8 PSI popoff is probably too low as well. I bet you are way too rich and thats why your RPMs wont come up.

  5. #5
    Was told tonight that my half throttle problem is too rich so now will be dropping mains Why aren't my top's (pistons) showing this? Bryan thanks for info. looks like you've ben down this road.....Going to try 105's as stated in polaris manual for F/A change to 3 single vortex's. Also with carb kits that were put in.. spring in kit (bright silver) took pop off to 38 psi with 105's .So trying to keep pop off close to stock I went back to orig. spring.(for 77.5's )That spring (also bright silver) was at 16psi (with 77.5) and now with 105's it dropped to 8 psi never checked pop off with 107.5's. Nate

  6. #6
    stubburnjdh's Avatar
    Join Date
    Jun 2009
    Location
    Front Royal VA
    Posts
    365
    You are probably dumping so much access gas on the pistons it is keeping them clean.

  7. #7
    Stubburnjdh, Thats the weird thing...They are Not clean they are Black with no visable signs of wash

  8. #8
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    popoff is not affected by jet changes.. only the arm spring and inlet needle size change popoff. I would go back to the stock settings, with the high speed needles turned out 1/2 turn from stock. In my 650, I had to go to 77.5 lows to make it run right. Run it and keep an eye on it. Wash takes a little time to develop

  9. #9
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    1. How are you viewing your piston wash? When using a light through the plug hole it sometimes is "shadowed" so it appears black.

    2. Jetting won't affect pop off as mentionerd above. ^^^^^ Only spring tensions and needle/seat sizes will affect PO pressure.

  10. #10
    Using a gun bore scope flexiable led light to view wash. The pop off changed when I put in 2.0 needle and seats 16psi down to 8 psi but with new springs (bright silver) that came with rebuild kits it went up to 38psi so I put old springs back in also bright silver back to 8psi. I'm going out now to pull carb's and drop back to 105's see what happens. I just think from what I've read here with the 780 F/A 77.5's are too small.I guess I'll have to order more jets and keep trying.If you pull head I assume you need new gaskets were's a good place to order them? Or I might have to buy one of those camera's you guys been bragging up. Thanks, Nate

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris freedom sport run at half throttle
    By billyhiggins42 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-10-2015, 10:05 AM
  2. Genesis Fuel Injected - low power, running rough at mid throttle
    By clint in forum Polaris Open Discussion
    Replies: 27
    Last Post: 01-12-2015, 09:26 AM
  3. SUV 1200 Runs "rough" at Full Throttle
    By PeaceRiverRider in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 06-13-2010, 08:18 PM
  4. Bogging at half throttle (1994 SL650)
    By Mezz2006 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 06-26-2009, 12:57 PM
  5. SLTX Bogging at Half Throttle
    By kl7741 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-14-2009, 11:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •