Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    sltx1050's Avatar
    Join Date
    Jul 2011
    Location
    hoffmen estates, illinois
    Posts
    163

    Polaris sltx 1050 impeller problems

    I have a 1997 polaris sltx 1050 I just rebuilt the top end, cleaned the carbs, did the ignition update kit
    And just got it out on the river today and first thing is it was idleing really low around 700 or 800 rpms And didnt wanna stay running but when I hit the gas it acked fine! So I fig!!!ure I have to bump up the idle ! I did check the plugs and pistons and they look fine! Second I was goig down the river at about 4500 rpms and about a mile down the river I heard a grinding noise then lost all jet power but the motor was fine! when I got it home and tore the impeller down and find the drive shaft and impeller were stripped, what could of caused this? Oh and if any one has a cheap used impeller and driveshaft that would help alot!


  2. #2
    stubburnjdh's Avatar
    Join Date
    Jun 2009
    Location
    Front Royal VA
    Posts
    365
    I lost my intake grate once and sucked up a rock just big enough to jam the drive shaft. Im not sure IF SBT repairs splines on impellers or just the blades but they have a cheap impeller swap deal. I'm sure someone on here has a shaft and impeller for you.

  3. #3
    sltx1050's Avatar
    Join Date
    Jul 2011
    Location
    hoffmen estates, illinois
    Posts
    163
    Ya thats what i was hoping for I had a trip planned for next weekend! And hope I can find &someone selling theres cheap
    So I can get it before the trip!

  4. #4
    sltx1050's Avatar
    Join Date
    Jul 2011
    Location
    hoffmen estates, illinois
    Posts
    163
    Thanks for telling me about the sbt company that would be sweet but they dont repair slines! so if anyone has a driveshaft and impeller let me know!

  5. #5
    sltx1050's Avatar
    Join Date
    Jul 2011
    Location
    hoffmen estates, illinois
    Posts
    163
    Well from what ive read in the service manual my pump must of been loose or on angle
    I just bought the whole jet pump and driveshaft off ebay for 250 not bad! but does anyone have a idea
    How to algain the pump with the motor?

  6. #6
    stubburnjdh's Avatar
    Join Date
    Jun 2009
    Location
    Front Royal VA
    Posts
    365
    Yep you need a pump alignment tool. Were are you located? Maybe someone near you has one. Beerdart made some for a bunch of us.

  7. #7
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31

  8. #8
    sltx1050's Avatar
    Join Date
    Jul 2011
    Location
    hoffmen estates, illinois
    Posts
    163
    Thanks that going to help! I live in hoffmen estates illinios, if anyone has the tool and in the area let me know!
    If not were could I get one or is there a way to make one?

  9. #9

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Quote Originally Posted by sltx1050 View Post
    Thanks that going to help! I live in hoffmen estates illinios, if anyone has the tool and in the area let me know!
    If not were could I get one or is there a way to make one?
    i have one in Orland Park if you want to come out and get it and bring it back of course i have shims too

  10. #10
    sltx1050's Avatar
    Join Date
    Jul 2011
    Location
    hoffmen estates, illinois
    Posts
    163
    ya that would be great thank you so much! i am paying for the pump and drive shaft today and hopfully have it thuesday or wednesday next week then i will pm you and oh coarse ill leave a deposit and most likely bring it back the next day! oncce agian thank you

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Polaris SLTX 1050 Problems
    By an32088 in forum Polaris Open Discussion
    Replies: 16
    Last Post: 06-15-2012, 02:31 AM
  2. Replies: 6
    Last Post: 05-16-2012, 03:15 PM
  3. Replies: 3
    Last Post: 09-08-2010, 09:07 AM
  4. 1996 Polaris sltx 1050 problem
    By John0227 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-09-2010, 02:39 PM
  5. '97 SLTX 1050 firing problem
    By chrismc in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-17-2007, 08:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •